Bug 241733 - RFE: allow the passing of options to program maps [NEEDINFO]
RFE: allow the passing of options to program maps
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-29 17:46 EDT by Jeffrey Moyer
Modified: 2014-06-02 09:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:01:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (jmoyer)


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Moyer 2007-05-29 17:46:44 EDT
Description of problem:
Currently, there is no way to pass any options to program maps.

Version-Release number of selected component (if applicable):
All.
Comment 4 Jeffrey Moyer 2009-08-21 11:30:13 EDT
I'm not getting any time for this, so I'll reassign it.  I haven't heard any further rumblings about this, so I think it's low priority.
Comment 5 Ian Kent 2009-11-24 22:32:14 EST
One way to allow program maps access to external values would be
to set the current macro table values in the environment before
execing the program. Someone wanting to pass information would
need only to define the value as macros. This would also prevent
us having to pollute the map syntax with custom options to define
the arguments.

Thoughts?
Comment 6 RHEL Product and Program Management 2014-03-07 07:38:02 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-02 09:01:23 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.