Bug 241734 - Network Manager causes periodic 802.11 network freezes
Network Manager causes periodic 802.11 network freezes
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-29 18:15 EDT by Steve Hill
Modified: 2008-04-04 04:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 04:31:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Hill 2007-05-29 18:15:01 EDT
Description of problem:
When network manager is running the 802.11 network repeatedly freezes for
several second every few minutes.  If you run a ping, all the packets eventually
get through but the packets transmitted during the freeze all get delivered in a
burst after several seconds.  The problem goes away if you shut down
NetworkManager and configure the interface through a ifcfg-wlan0 file.

The 802.11 device is an Intel iwl3945 connecting to a LinkSys WRT54GL running
OpenWRT with 128 bit WEP.  Kernel version 2.6.21-1.3194.fc7

Version-Release number of selected component (if applicable):
NetworkManager-0.6.5-2.fc7

How reproducible:
Easilly

Steps to Reproduce:
1. Start up NetworkManager and NetworkManagerDispatcher
2. Log in to Gnome
3. Allow NetworkManager to associate with an access point
4. Start a ping going across the 802.11 network
5. Wait for a few minutes.
  
Actual results:
Note the timestamps on the below ping:

64 bytes from 84.92.27.250: icmp_seq=135 ttl=64 time=1.41 ms
64 bytes from 84.92.27.250: icmp_seq=136 ttl=64 time=1.34 ms
64 bytes from 84.92.27.250: icmp_seq=137 ttl=64 time=5715 ms
64 bytes from 84.92.27.250: icmp_seq=138 ttl=64 time=4718 ms
64 bytes from 84.92.27.250: icmp_seq=139 ttl=64 time=3719 ms
64 bytes from 84.92.27.250: icmp_seq=140 ttl=64 time=2720 ms
64 bytes from 84.92.27.250: icmp_seq=141 ttl=64 time=1721 ms
64 bytes from 84.92.27.250: icmp_seq=142 ttl=64 time=726 ms
64 bytes from 84.92.27.250: icmp_seq=143 ttl=64 time=1.49 ms
64 bytes from 84.92.27.250: icmp_seq=144 ttl=64 time=1.34 ms

Expected results:
The presence of NetworkManager should not affect the network's performance

Additional info:
I am unsure if this is a problem with NetworkManager or the driver.  I presume
that Network manager asks the NIC to scan for other access points periodically -
should the NIC be expected to do this without disrupting the network connection?
Comment 1 Steve Hill 2007-06-23 06:56:10 EDT
Each time the network freezes up it lasts for 7 seconds and results in the
kernel logging:

iwl3945: REPLY_ADD_STA failed

So it appears to be a problem with the iwl3945 driver which is being triggered
by something that NetworkManager is doing.

I've opened an upstream bug against the iwlwifi driver:
http://bughost.org/bugzilla/show_bug.cgi?id=1338
Comment 2 Bug Zapper 2008-04-03 21:00:21 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 3 Steve Hill 2008-04-04 04:31:38 EDT
Seems ok with the very latest Fedora 8 kernel.  Although the iwl3945 driver
seems to be one of those things that regularly breaks on updates so I wouldn't
be surprised it this reoccurs.

NOTE: This bug was filed under Fedora 7, *NOT* Rawhide.

Note You need to log in before you can comment on or make changes to this bug.