Bug 241736 - Unable to modify vpn connection settings
Summary: Unable to modify vpn connection settings
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-29 23:16 UTC by James Bowes
Modified: 2013-01-10 09:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 22:29:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Bowes 2007-05-29 23:16:40 UTC
NetworkManager-vpnc-0.6.4-3.fc7

Under NetworkManger/VPN Connections/Configure VPN.../<Connection name>/Edit the
'Apply' button is by default sensitive, and becomes insensitive when any
settings are changed, unless the NAT keep alive settings (and only these
settings) are changed, in which case the Apply button is again sensitive.

As a result, unless you are only changing your NAT keepalive settings, you
cannot edit connection settings.

Comment 1 Denis Leroy 2007-06-14 22:20:01 UTC
Well, when you select 'Use NAT keepalive' or 'Use domain for authentication',
the validation code actually checked the value you entered. That means that
"Apply" will only become sensitive again *IF* you enter a sensible value in the
field you just enabled... 

I can't seem to reproduce a case when apply is disabled when it should be on.
Could you give me a specific scenario to reproduce ?



Comment 2 James Bowes 2007-06-14 22:29:48 UTC
I can't reproduce now either, so I must have been having a bad day when I
reported this. Closing.


Note You need to log in before you can comment on or make changes to this bug.