Bug 241743 - [RFE] Japanese messages are displayed in hex number
[RFE] Japanese messages are displayed in hex number
Status: CLOSED DUPLICATE of bug 171664
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-30 01:01 EDT by Mamoru TASAKA
Modified: 2014-01-21 17:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 14:09:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2007-05-30 01:01:42 EDT
Description of problem:
Error messages in Japanese by yum are displayed in
hexadecimal number

Version-Release number of selected component (if applicable):
yum-3.2.0-1.fc7

How reproducible:
100% (when error occurs and Japanese error
messages are displayed)

Steps to Reproduce:
1. Try "yum check-update" several times
2. Sometimes one mirror yum tries to use is corrupted.
3.
  
Actual results:
[root@localhost yum.repos.d]# yum --disablerepo=koji check-update 
<snip>
http://ftp.nara.wide.ad.jp/pub/Linux/fedora/core/development/i386/os/repodata/repomd.xml:
[Errno 4] IOError: <urlopen error (101,
'\xe3\x83\x8d\xe3\x83\x83\xe3\x83\x88\xe3\x83\xaf\xe3\x83\xbc\xe3\x82\xaf\xe3\x81\xab\xe5\xb1\x8a\xe3\x81\x8d\xe3\x81\xbe\xe3\x81\x9b\xe3\x82\x93')>
Trying other mirror.
development               100% |=========================| 2.1 kB    00:00     


Expected results:
In this case:
IOError: <urlopen error (101, "ネットワークに届きません")>
Trying other mirror.

Additional info:
In this case:
[root@localhost yum.repos.d]# echo -e
'\xe3\x83\x8d\xe3\x83\x83\xe3\x83\x88\xe3\x83\xaf\xe3\x83\xbc\xe3\x82\xaf\xe3\x81\xab\xe5\xb1\x8a\xe3\x81\x8d\xe3\x81\xbe\xe3\x81\x9b\xe3\x82\x93'
ネットワークに届きません

"ネットワークに届きません" is Japanese message meaning "unreachable
to network".
Comment 1 Jeremy Katz 2007-09-13 14:09:40 EDT

*** This bug has been marked as a duplicate of 171664 ***

Note You need to log in before you can comment on or make changes to this bug.