Bug 241756 - After upgrade, the WebUI is broken because the CSS are not uploaded anew -- Ctrl + R is needed.
After upgrade, the WebUI is broken because the CSS are not uploaded anew -- C...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Steve Salevan
:
Depends On:
Blocks: 173432
  Show dependency treegraph
 
Reported: 2007-05-30 08:31 EDT by Jan Pazdziora
Modified: 2007-10-29 22:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 22:15:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of broken layout (102.59 KB, image/png)
2007-05-30 08:31 EDT, Jan Pazdziora
no flags Details

  None (edit)
Description Jan Pazdziora 2007-05-30 08:31:53 EDT
Description of problem:

After upgrading 3.7 or 4.* Satellite to version 5.0.0, the WebUI is broken,
presumably because the CSS have changed significantly but the browser does not
know about it and does not reload them, unless forced.

Version-Release number of selected component (if applicable):

-> 5.0.0

How reproducible:

Observed twice.

Steps to Reproduce:
1. Have a 3.7 Satellite, work with it via WebUI.
2. Upgrade it to 5.0.
3. Go to the WebUI.
  
Actual results:

The layout is broken.

Expected results:

Nice layout.

Additional info:

It is possible to fix this by reloading the page (Ctrl + R in my Galeon).

I wonder if:

1) We should use different CSS filenames since the change is so significant. But
it's probably too late into the game for this change.
2) We should put that Ctrl + R step into the upgrade scenario files.
Comment 1 Jan Pazdziora 2007-05-30 08:31:53 EDT
Created attachment 155671 [details]
Example of broken layout
Comment 2 Jan Pazdziora 2007-05-30 08:51:41 EDT
Something like this could be added to rhn-satellite-5-upgrade-scenario-1?.txt:

 16. Test/verify new RHN Satellite:
    website: check that you can log in, that the basic data is sane, and the
             custom RPMs can be downloaded.
+            a refresh (Ctrl + R) of the browser can be needed should the
+            layout of pages be broken.
             a thorough evaluation (with some depth) is advised
    monitoring: perform steps 13a and 13b (if needed) at this point.
    hosted: ensure the satellite is a satellite according to the hosted site
Comment 3 Clifford Perry 2007-05-30 09:08:34 EDT
Suggest to change the 'can' with a 'could'
Comment 4 Jan Pazdziora 2007-05-30 09:15:52 EDT
Change committed to SVN, revision 117006.
Comment 5 Jan Pazdziora 2007-06-04 05:01:23 EDT
With rhn-upgrade-5.0.0-4.noarch.rpm on webqa, moving ON_QA.
Comment 6 Steve Salevan 2007-06-06 12:10:14 EDT
QA Contact -> ssalevan

Found appropriate text in latest rhn-upgrade RPM; thus this bug is VERIFIED.
Comment 7 Steve Salevan 2007-06-19 16:23:13 EDT
Looks good on Stage-verified Satellite; moving to RELEASE_PENDING.
Comment 8 Brandon Perkins 2007-06-25 22:15:11 EDT
Closed for Satellite 500 Release.

Note You need to log in before you can comment on or make changes to this bug.