Bug 241767 - mkfs.ext3 fails cryptically
mkfs.ext3 fails cryptically
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-30 10:24 EDT by Eric Sandeen
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 12:56:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2007-05-30 10:24:07 EDT
# mkfs.ext3 -b 1024 /dev/sdb1 2047000000
mke2fs 1.39 (29-May-2006)
Filesystem label=
OS type: Linux
Block size=1024 (log=0)
Fragment size=1024 (log=0)
255875072 inodes, 2047000000 blocks
102350000 blocks (5.00%) reserved for the super user
First data block=1
Maximum filesystem blocks=2114191360
249878 block groups
8192 blocks per group, 8192 fragments per group
1024 inodes per group
Superblock backups stored on blocks: 
        8193, 24577, 40961, 57345, 73729, 204801, 221185, 401409, 663553, 
        1024001, 1990657, 2809857, 5120001, 5971969, 17915905, 19668993, 
        25600001, 53747713, 128000001, 137682945, 161243137, 483729409, 
        640000001, 963780609, 1451188225

mkfs.ext3: Could not allocate block in ext2 filesystem while trying to allocate
filesystem tables

same on a loopback file:

# touch fsfile
# mkfs.ext3 -F -b 1024 fsfile 2047000000
mke2fs 1.39 (29-May-2006)
Filesystem label=
OS type: Linux
Block size=1024 (log=0)
Fragment size=1024 (log=0)
255875072 inodes, 2047000000 blocks
102350000 blocks (5.00%) reserved for the super user
First data block=1
Maximum filesystem blocks=2114191360
249878 block groups
8192 blocks per group, 8192 fragments per group
1024 inodes per group
Superblock backups stored on blocks: 
        8193, 24577, 40961, 57345, 73729, 204801, 221185, 401409, 663553, 
        1024001, 1990657, 2809857, 5120001, 5971969, 17915905, 19668993, 
        25600001, 53747713, 128000001, 137682945, 161243137, 483729409, 
        640000001, 963780609, 1451188225

mkfs.ext3: Could not allocate block in ext2 filesystem while trying to allocate
filesystem tables
Comment 1 Eric Sandeen 2007-07-19 15:58:04 EDT
Ok, the issue is that we want so many inodes by default, there's no room for the
inode table in the first block group.

Seems like mke2fs could be a bit more informative about what is going on; if I
reduce the nr. of inodes,  mkfs completes ok...

Bug 241765 is more worrisome, it actually completes but is corrupt.
Comment 2 Eric Sandeen 2007-07-20 18:12:27 EDT
Patch sent upstream
Comment 4 Eric Sandeen 2007-10-16 12:56:54 EDT
Since I'm the only one who's ever hit this, and no customer has seen it on RHEL,
I'm content to not churn this fix into RHEL; we can pick it up on the next
e2fsprogs release - should be in e2fsprogs-1.40.3.

Note You need to log in before you can comment on or make changes to this bug.