Bug 241795 - Bad numactl command hangs the system
Summary: Bad numactl command hangs the system
Status: CLOSED DUPLICATE of bug 229084
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.0
Hardware: ia64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-30 18:16 UTC by Nick Dokos
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-08 16:13:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console output (7.93 KB, text/plain)
2007-05-30 18:16 UTC, Nick Dokos
no flags Details

Description Nick Dokos 2007-05-30 18:16:13 UTC
Description of problem:
Executing a command like this: numactl --cpubind <N> --membind <N> <command> on
an interleaved system produces the attached register dump and the system hangs:
you can ping it but that's about it.

Version-Release number of selected component (if applicable):
kernel 2.6.18-1.1

How reproducible:
Always.

Steps to Reproduce:
1. On an interleaved IA64 system (I used an rx8640, but I have no
reason to believe it's any different on an rx8620 or a Superdome),
say
     numactl --cpubind 0 --membind 0 ls


2. 
3.
  
Actual results:
System hangs.
See attachment for console output.

Expected results:
Command should return an error.

Additional info:
Lee Schermerhorn tried a 2.6.22-rc2-mm1 kernel on the same machine - it behaves
properly: the command returns an error as it should and nothing bad happens.

Comment 1 Nick Dokos 2007-05-30 18:16:13 UTC
Created attachment 155719 [details]
Console output

Comment 2 Doug Chapman 2007-05-30 18:55:48 UTC
Nick,

Was it just the kernel that was different between what you tried and what worked
for Lee or was it a different version of the numactl cmd line util also?

- Doug


Comment 3 Nick Dokos 2007-05-30 19:39:27 UTC
Doug, it was just the kernel. Everything else stayed the same.


Comment 4 Doug Chapman 2007-06-08 16:13:28 UTC
I have verified that this is already fixed in the latest RHEL5.1 kernels. 
Appears to be a dup of 229084.


*** This bug has been marked as a duplicate of 229084 ***


Note You need to log in before you can comment on or make changes to this bug.