Bug 241796 - Group ACLs ignored in NFS when user belongs > 16 groups
Group ACLs ignored in NFS when user belongs > 16 groups
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-30 14:24 EDT by James T
Modified: 2014-06-18 03:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-01 10:58:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James T 2007-05-30 14:24:10 EDT
Description of problem:

I am trying to workaround the permission denied issues in NFS when a user
belongs to more than 16 supplementary groups. One of the suggested workarounds
is to assign ACLs to the directories. This works fine if I assign an ACL for
each individual user. If I assign an ACL for a group it does not work UNLESS the
user belongs to fewer than 16 groups. 


$ ls -l
drwxr-x---+ 4 data IPTS-142 4096 May 30 09:10 IPTS-142

$ getfacl IPTS-142/
# file: IPTS-142
# owner: snsdata
# group: IPTS-142
user::rwx
group::r-x
group:hfiradmin:r-x
mask::r-x
other::---

$ cd IPTS-142/
-bash: cd: IPTS-142/: Permission denied

$ groups
users test5152005 hfiradmin etc...
Comment 1 Jeff Layton 2007-06-01 10:58:26 EDT
This is NOTABUG. Since you're using groups in your ACL's, you'll be subject to
the same set of limitations as using groups with regular unix permissions. The
RPC spec regrettably specifies a hard limit of 16 groups.

You'll need to specify users individually in your ACL's if you plan to use this
as a workaround.

Note You need to log in before you can comment on or make changes to this bug.