Bug 241829 - tastymenu does not build on f7 / rawhide
Summary: tastymenu does not build on f7 / rawhide
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tastymenu   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kelly Miller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-30 22:10 UTC by Doncho Gunchev
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-31 21:42:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Doncho Gunchev 2007-05-30 22:10:25 UTC
Description of problem:
tastymenu does not build on f7 rawhide - missing BuildRequires: arts-devel,
qt-devel, libXext-devel

Version-Release number of selected component (if applicable):
0.8.6

How reproducible:
always (if these dependencies are not installed by chance)

Steps to Reproduce:
1. wget
2. rpmbuild --define 'dist .f7' --rebuild tastymenu-*.src.rpm

Actual results:
can not find X, arts, qt, ...

Expected results:
It's just too tasty not to have it running in f7 ;-)

Additional info:

Here's what I changed in the .spec to get it rebuild:
BuildRequires:  kdelibs-devel >= 3.0.0, gettext, arts-devel, qt-devel, libXext-devel
...
%build
. /etc/profile.d/qt.sh
%configure --disable-rpath --libdir=%{_libdir}/kde3 \
   --enable-new-ldflags \
   --enable-final \
   --x-libraries=/usr/lib/xorg --x-includes=/usr/include/xorg

Not sure if '. /etc/profile.d/qt.sh' is needed though. Some more dependencies
are probably missing too. Thanks for the nice applet!

Comment 1 Kelly Miller 2007-05-30 22:57:42 UTC
The odd thing about that is that kdelibs-devel should require qt-devel and 
arts-devel, and qt-devel requires libXext-devel...

Maybe it's an error with kdelibs-devel itself?

Comment 2 Kelly Miller 2007-05-30 23:41:04 UTC
I just ran mock on it using the development repositories, and the source rpm 
built, no problem.

Since you listed 0.8-6, did you note that I released a new source package 
(with the F7 build), 0.8.2-1?

Comment 3 Doncho Gunchev 2007-05-31 21:42:13 UTC
You are right:
$ rpm -q --whatrequires qt-devel
kdelibs-devel-3.5.6-9.fc7
arts-devel-1.5.6-4.fc7

I can't tell you how did I get in this situation (used F7t4 KDE Live CD and 
only yum after that), but... (yum got crazy?)

Anyway, it's not this package's bug. Using 0.8.2-1.fc7 from koji now, thanks 
again.


Note You need to log in before you can comment on or make changes to this bug.