Bug 241850 - Various Mono deps not available for PPC64
Various Mono deps not available for PPC64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: blam (Show other bugs)
rawhide
ppc64 Linux
low Severity medium
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ge...
: FutureFeature
Depends On:
Blocks: FE-ExcludeArch-ppc64/F-ExcludeArch-ppc64
  Show dependency treegraph
 
Reported: 2007-05-31 02:03 EDT by Peter Gordon
Modified: 2012-01-13 14:53 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-13 14:53:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gordon 2007-05-31 02:03:55 EDT
Blam currently fails to build on PPC64 due to several missing dependencies. As
required for such ExcludeArch inclusions, this bug is to track the resolution of
those and is set to block the PPC64 tracker bug.

The following packages are not available for PPC64:
 * mono-devel
 * gecko-sharp2-devel
 * gnome-sharp-devel
 * dbus-sharp-devel >= 0.60
 * gtk-sharp2-devel
 * gtk-sharp2-gapi

This is when attempting to build 1.8.3-4 (CVS tag blam-1_8_3-4_fc8).
Comment 1 David Nielsen 2007-07-05 13:49:34 EDT
Adding ndesk-dbus to this list, same problem but as a reminder to myself to
build ndesk-dbus on ppc64 once possible.

http://koji.fedoraproject.org/koji/taskinfo?taskID=57121
Comment 2 Bug Zapper 2008-05-13 22:57:34 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Michel Alexandre Salim 2008-07-15 09:34:25 EDT
gnome-keyring-sharp depends on ndesk-dbus, I'm Cc:ing myself as well
Comment 4 Peter Gordon 2008-07-15 20:52:56 EDT
According to the ExclusiveArch of the mono package, it (an thus these
dependencies which would require it) are still not built for PPC64, so I'm
changing the version back to 'Rawhide'.
Comment 5 John Poelstra 2008-09-26 23:21:45 EDT
adding FutureFeature keyword so 'rawhide' version remains at GA of F10
Comment 6 Alp Toker 2008-11-04 05:11:55 EST
(In reply to comment #1)
> Adding ndesk-dbus to this list, same problem but as a reminder to myself to
> build ndesk-dbus on ppc64 once possible.
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=57121

Hi,

ndesk-dbus and ndesk-dbus-glib do not need to be rebuilt for different architectures. A single build works on any architecture -- it's really no different than a perl or shell script.
Comment 7 Alp Toker 2008-11-04 05:18:32 EST
(In reply to comment #0)
> Blam currently fails to build on PPC64 due to several missing dependencies. As
> required for such ExcludeArch inclusions, this bug is to track the resolution of
> those and is set to block the PPC64 tracker bug.
> 
> The following packages are not available for PPC64:
>  * mono-devel
>  * gecko-sharp2-devel

Note also that gecko-sharp2 is discontinued upstream. blam 1.8.6 and later use webkit-sharp.
Comment 8 Toshio Ernie Kuratomi 2009-04-18 12:42:32 EDT
I've just rebuilt mono for ppc64.  Care to give these another try?

Note You need to log in before you can comment on or make changes to this bug.