Bug 241887 - Wrong ldap config and useless nisplus settings in nsswitch.conf
Summary: Wrong ldap config and useless nisplus settings in nsswitch.conf
Status: CLOSED DUPLICATE of bug 462549
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: authconfig   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-31 14:32 UTC by Klaus Ethgen
Modified: 2008-10-01 10:05 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 09:42:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 241657 None None None Never

Description Klaus Ethgen 2007-05-31 14:32:56 UTC
This is a split of 241657:

When using "auth --enablemd5 --enableshadow --enablecache --enablekrb5 --
enableldap -- ldapserver="ldaps01.ethz.ch" --
ldapbasedn="ou=isg,ou=inf,ou=auth,o=ethz,c=ch" -- enableldaptls" in the 
kickstart the settings for ldap are not working properly. This should produce a 
"uri ldaps://..." but in ldap.conf will be "uri ldap://...".

Also the nsswitch.conf has some nisplus settings which is useless for me as we 
do not use it.

Comment 1 Tomas Mraz 2008-10-01 09:42:05 UTC
The correct options of authconfig for ldaps is
--enableldap --ldapserver=ldaps://ldaps01.ethz.ch --ldapbasedn="ou=isg,ou=inf,ou=auth,o=ethz,c=ch"

Unfortunately this still needs a fix in RHEL-5 version of nss_ldap to work correctly.

The nisplus settings in nsswitch.conf are harmless.

*** This bug has been marked as a duplicate of bug 462549 ***

Comment 2 Klaus Ethgen 2008-10-01 09:55:03 UTC
So as I see, 462549 is a duplicate of this bug, not the way around!

This bug report is from 2007-05-31 and the other is from 2008-09-16.

Comment 3 Tomas Mraz 2008-10-01 10:05:46 UTC
What bug is closed as duplicate is decided by the developer according to the info which is included in the bug report not just by looking at the date of the report.


Note You need to log in before you can comment on or make changes to this bug.