Bug 241896 - /etc/profile.d/lang.sh calls unicode_stop without unicode_start
/etc/profile.d/lang.sh calls unicode_stop without unicode_start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
6
All Linux
low Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On: 241893
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 11:07 EDT by Thomas Steudten
Modified: 2014-03-16 23:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: 8.64-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 01:55:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Steudten 2007-05-31 11:07:15 EDT
On console/vt /etc/init.d/functions sources /etc/profile.d/lang.sh and this
script  calls /bin/unicode_stop (which has a bug "missing FD in test -t"),
without calling unicode_start.

This gives trouble in /etc/redhat-lsb/lsb_pidofproc, because this output is used
in an expression like pid=$(pidofproc test), and the output from
/bin/unicode_stop  fills the pid variable, if no process is found by pidof, and
so the test "test -z "$pid" will fail.

/etc/init.d/tor use the lsb-pidofproc version.

Reproduce on console/vt - not in xterm:
1) /etc/init.d/tor stop
2) sh -x /etc/init.d/tor status |cat -v
See $pid variable..
Comment 1 Bill Nottingham 2008-02-26 01:55:16 EST
This should be fixed in 8.64-1.

Note You need to log in before you can comment on or make changes to this bug.