Bug 241907 - RHEL 4.5.0 release notes -- LVM failover, new feature
RHEL 4.5.0 release notes -- LVM failover, new feature
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
low Severity medium
: ---
: ---
Assigned To: Don Domingo
Cluster QE
:
Depends On:
Blocks: Cluster4u5relnotes
  Show dependency treegraph
 
Reported: 2007-05-31 12:19 EDT by Paul Kennedy
Modified: 2015-04-19 20:47 EDT (History)
13 users (show)

See Also:
Fixed In Version: 4.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 11:58:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rel notes for ha lvm (2.39 KB, text/plain)
2007-06-12 17:15 EDT, Corey Marthaler
no flags Details

  None (edit)
Description Paul Kennedy 2007-05-31 12:19:59 EDT
Description of problem:

Add release notes for new feature, LVM failover, with Red Hat Cluster Suite for
RHEL 4.5.

jbrassow, please provide content for this. Thanks.
Comment 1 Corey Marthaler 2007-06-04 12:45:49 EDT
The following is the start of a list of issues that QE would like to see in the
documentation.

A. Only one HA lvm service is allowed per lvm volume group. This is because,
with multiple services, you can end up with mulitple machines attemping to
update the vg metadata at the same time, leading to corruption. The lastest
version of lvm.sh should check and fail if this is not the case.  

It is also a bad idea to create *any* other lvs on a vg with an HA lvm service
on it, due to the risk of vg metadata corruption.

B. The lvm.conf file has to have a locking type equal to 1:
'locking_type = 1'
As well as a tag including the machine tag name for HA lvm service activation:
'volume_list = [ "VolGroup00", "@machinename" ]'

C. When creating mirrors for use with HA lvm, you need to add a tag for the
machine that is do the creation. 
'lvcreate -m 1 --addtag machinename ...'

Without this tag, that mirror creation will fail due to the log not being able
to activate. Once the mirror is created and active, that mirror will then need
to be deactivated and the tag removed, before starting HA lvm services.


More issues to come... :)
Comment 2 Don Domingo 2007-06-04 18:05:50 EDT
notes added to Release Notes; please view the mockup at:

http://intranet.corp.redhat.com/ic/intranet/RHClusterSuite4u5releasenotesMOCKUP.html

all added under "Known Issues".

i need more clarification on your third item, though (which i did not add yet).
is 'lvcreate -m 1 --addtag machinename ...' a command you need to run at a
terminal, or is it a tag you should add as is to the lvm.conf? 

also, does "machinename" in the tag correspond to a machine being "mirrored"?

please advise. thanks!

 
Comment 3 Corey Marthaler 2007-06-05 12:49:21 EDT
Don, 

I did not see anything related to lvm failover in the link you posted.
Also, 'lvcreate -m 1 --addtag machinename ...' is the command that will need to
be run at the terminal when creating a mirror to be used with HA lvm. The
important part of the command being "--addtag machinename", the rest of the
command will depend on how the user configures their mirror.

Corey
Comment 4 Jonathan Earl Brassow 2007-06-06 16:34:09 EDT
moving this to "component = rgmanager", since that's where the script lives and
that is what actually moves the service around.
Comment 5 Jonathan Earl Brassow 2007-06-06 17:33:52 EDT
<release_notes>
Logical Volume Manager fail-over - also known as, Highly Available LVM (HA LVM)
- is now possible with rgmanager.  This provides a way to use LVM in an
activate/passive environment.

The most compelling application of HA LVM is the mirroring of two distinct
SAN-connected sites.  One site can suffer complete failure (machine and storage)
and the other can continue serving content.

Proper setup is required for correct operation.  Setup consists of the following
steps:
1) Create the logical volume.  Only one logical volume is allowed per volume
group in HA LVM.  Example:
prompt> pvcreate /dev/sd[cde]1
prompt> vgcreate my_volume_group /dev/sd[cde]1
prompt> lvcreate -L 10G -n my_logical_volume my_volume_group

2) Edit /etc/cluster/cluster.conf to include the newly created logical volume as
a resource in one of your services.  (Optionally, you can use the
system-config-cluster or conga GUIs.)  Example resource manager section from
/etc/cluster/cluster.conf:

<rm>
  <failoverdomains>
    <failoverdomain name="FD" ordered="1" restricted="0">
      <failoverdomainnode name="neo-04" priority="1"/>
      <failoverdomainnode name="neo-05" priority="2"/>
    </failoverdomain>
  </failoverdomains>

  <resources>
    <lvm name="lvm" vg_name="my_volume_group" lv_name="my_logical_volume"/>
    <fs name="FS" device="/dev/my_volume_group/my_logical_volume"
        force_fsck="0" force_unmount="1" fsid="64050" fstype="ext3"
        mountpoint="/mnt" options="" self_fence="0"/>
  </resources>

  <service autostart="1" domain="FD" name="serv" recovery="relocate">
    <lvm ref="lvm"/>
    <fs ref="FS"/>
  </service>
</rm>

3) Edit the "volume_list" field in /etc/lvm/lvm.conf.  Include the name of your
root volume group and your machine's name as given in /etc/cluster/cluster.conf
preceded by an "@".  Example from /etc/lvm/lvm.conf:

volume_list = [ "VolGroup00", "@neo-01" ]

4) Update your initrd on all your cluster machines.  Example:

prompt> new-kernel-pkg --mkinitrd --initrdfile=/boot/initrd-halvm-`uname -r`.img
--install `uname -r`

5) Reboot all of your machines to ensure the correct initrd is in-use.

</release_notes>

Corey, can you verify the above steps?  I think if you do it this way, you don't
even have to mention tags.
Comment 6 Corey Marthaler 2007-06-12 10:34:27 EDT
The statement about, "One site can suffer complete failure (machine and storage)
and the other can continue serving content" is a little misleading, in that it
*has* to be a complete failure or a machine failure. If there is a storage
failure on one site, the other wont continue serving content. This issue is
documented in bz 242798.
Comment 7 Corey Marthaler 2007-06-12 15:06:52 EDT
You need to make the filesystem at the end of Step 1:

1) Create the logical volume.  Only one logical volume is allowed per volume
group in HA LVM.  Example:
prompt> pvcreate /dev/sd[cde]1
prompt> vgcreate my_volume_group /dev/sd[cde]1
prompt> lvcreate -L 10G -n my_logical_volume my_volume_group
prompt> mkfs.ext3 /dev/my_volume_group/my_logical_volume
Comment 8 Corey Marthaler 2007-06-12 17:15:55 EDT
Created attachment 156830 [details]
rel notes for ha lvm

Here are the completed rel notes verified by QA.
Comment 9 Don Domingo 2007-06-12 20:29:21 EDT
item added to cluster release notes, please verify:

http://intranet.corp.redhat.com/ic/intranet/RHClusterSuite4u5releasenotesMOCKUP.html

once verified, we will push it to live. thanks!
Comment 10 Paul Kennedy 2007-06-15 16:12:14 EDT
Further review comments:

"New Features" section, "LVM Failover", paragraph 3 (starting with "The most
compelling..."):

1. Sentence 2 needs further clarification to clearly show that when one site
fails, another site takes over for it.
2. s/neo-04/neo-01/ and s/neo-05/neo-02/


"Known Issues" section:
1. Make "HA lvm" reference the same as new features section (i.e. HA LVM - no
bold, all caps)
2. HA LVM is introduced later as a new feature, yet the "known issues" are
explained here... readers won't understand what is being talked about.

Revise "Known Issues" section:

    * The latest version of lvm.sh should check and fail if this is not the
case.  Do not create another logical volume on a volume group with an HA lvm
service on it, due to the risk of volume group metadata corruption.


Don, I updated the Wiki mockup page to address the comments:
http://intranet.corp.redhat.com/ic/intranet/RHClusterSuite4u5releasenotesMOCKUP.html

Jon (jbrassow@redhat.com) and Corey (cmarthal@redhat.com) have reviewed the
modified mockup page and approve. Please change source accordingly and repost on
mockup page for final approval. Thanks.


Comment 11 Don Domingo 2007-06-17 20:09:47 EDT
these revisions are now in source. please refer to mockup and let me know when
we can post to live.

thanks!
Comment 12 Jonathan Earl Brassow 2007-06-18 11:02:37 EDT
looks good

 brassow
Comment 13 Corey Marthaler 2007-06-18 11:09:44 EDT
looks good to me as well.
Comment 16 Paul Kennedy 2007-06-22 17:26:49 EDT
Content is available in release notes here:
http://www.redhat.com/docs/manuals/csgfs/release-notes/CS_4-RHEL4U5-relnotes.html


Note You need to log in before you can comment on or make changes to this bug.