Bug 241912 - mysql-server uninstall script only removes user mysql
mysql-server uninstall script only removes user mysql
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom Lane
:
: 244541 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 12:54 EDT by Martin Jürgens
Modified: 2013-07-02 23:13 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.0.45-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 04:28:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2007-05-31 12:54:27 EDT
Description of problem:
The uninstall script of mysql-server only removes the user mysql although the
install script adds the user + the group mysql.


Version-Release number of selected component (if applicable):


How reproducible:
Every Time

Steps to Reproduce:
1. Uninstall all mysql related things
2. Install all mysql related things
3.
  
Actual results:
Mysql does not start because of missing user and group mysql.


Expected results:
Mysql should start, the uninstall script should remove the group mysql, also.

Additional info:
Comment 1 Tom Lane 2007-05-31 16:19:58 EDT
actually the plan is to remove the userdel action altogether; it's contrary to
Fedora packaging guidelines.
Comment 2 Martin Jürgens 2007-06-09 06:22:15 EDT
the problem is that when you removed mysql in fedora 7, you are not able to
install it again without knowing that you have to remove the group mysql.

i do not know what your plans are, but it would be really great to have that
fixed in f7 and rhel5 (also happens there), just for the records :)
Comment 3 Tom Lane 2007-06-16 22:58:53 EDT
*** Bug 244541 has been marked as a duplicate of this bug. ***
Comment 4 Tom Lane 2007-07-22 19:50:27 EDT
Done in mysql-5.0.45-1, should appear in F7 testing shortly.
Comment 5 Fedora Update System 2007-07-23 11:44:44 EDT
mysql-5.0.45-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2007-09-25 04:27:56 EDT
mysql-5.0.45-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.