Bug 241917 - gnome-sudoku needs to call g_thread_init() before all other Glib functions.....
gnome-sudoku needs to call g_thread_init() before all other Glib functions.....
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 13:43 EDT by Tom London
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 22:12:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2007-05-31 13:43:20 EDT
Description of problem:
Running latest Rawhide, I get this when starting gnome-sudoku from a terminal
window:

[tbl@localhost ~]$ python /usr/bin/gnome-sudoku

***MEMORY-WARNING***: gnome-sudoku[6615]: GSlice: g_thread_init() must be called
before all other GLib functions; memory corruption due to late invocation of
g_thread_init() has been detected; this program is likely to crash, leak or
unexpectedly abort soon...

Program behavior is erratic.

Version-Release number of selected component (if applicable):
gnome-games-2.19.2-1.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andreas Røsdal 2007-06-05 13:51:34 EDT
Hi!  This has now been fixed in our SVN repository, and will be included in the
next release of gnome-sudoku.
Comment 2 Matthew Miller 2007-06-20 22:12:33 EDT
There's a bunch of similar bugs -- apparently the root problem is in glib2
itself. Therefore, these probably should all be closed as duplicates of bug #241925.

Note You need to log in before you can comment on or make changes to this bug.