Bug 241922 - Problems that prevent good bug reporting
Problems that prevent good bug reporting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 14:18 EDT by Andrew D. Stadler
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 11:40:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash log (5.08 KB, text/plain)
2007-05-31 14:18 EDT, Andrew D. Stadler
no flags Details

  None (edit)
Description Andrew D. Stadler 2007-05-31 14:18:13 EDT
I recently experienced a crash while doing a typical "software updater".  This
bug is already filed.

While doing this, I noticed a few things that made the bug reporting process
less than ideal.  I don't know if this is specific to pup/pirut or more generic;
 Please refile appropriately if necessary.

1.  The crash dialog recommends going to Fedora's bugzilla to file the bug.  It
helpfully provides the URL.  But the URL is neither clickable nor selectable, so
the user must manually type it into the browser.

2.  The dialog also recommends saving the crash log to attach it to the bug. 
Great recommendation.  Problem:  The dialog goes away after saving the crash, so
all of the helpful information (e.g. the URL noted above) is also lost.  The
user no longer knows where to go or what to do.  Fix:  Saving the crash log
shouldn't close the dialog.

3.  Faced with only the crash log, I tried to file the bug.  I found that the
first few lines of the crash log provided missing or even misleading information
about where to file the bug:

Component: Software Updater
Summary: TB631e9c38 urllib2.py:544:http_error_302:TypeError: cannot concatenate 
'str' and 'instance' objects
Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
 
When you go to fedora/redhat bugzilla and try to file a bug, you discover that
there's no component "software updater" or "pup".  The bugs have to go under
"pirut".
Comment 1 Andrew D. Stadler 2007-05-31 14:18:13 EDT
Created attachment 155833 [details]
crash log
Comment 2 Jeremy Katz 2007-06-05 11:40:10 EDT
(In reply to comment #0)
> While doing this, I noticed a few things that made the bug reporting process
> less than ideal.  I don't know if this is specific to pup/pirut or more generic;
>  Please refile appropriately if necessary.

This covers a few different things; in the future, it's a lot easier if you file
each thing separately so that they can be tracked and reassigned accordingly. 
In this case, you got lucky in that I work on all of the relevant pieces :)
 
> 1.  The crash dialog recommends going to Fedora's bugzilla to file the bug.  It
> helpfully provides the URL.  But the URL is neither clickable nor selectable, so
> the user must manually type it into the browser.

Clickable is problematic due to apps running as root and not wanting to run the
browser as root; but made the change so that the text should at least be selectable.

> 2.  The dialog also recommends saving the crash log to attach it to the bug. 
> Great recommendation.  Problem:  The dialog goes away after saving the crash, so
> all of the helpful information (e.g. the URL noted above) is also lost.  The
> user no longer knows where to go or what to do.  Fix:  Saving the crash log
> shouldn't close the dialog.

Rather than this, I've adjusted the text so that you get the URL again when
you're told that it saved successfully.

> 3.  Faced with only the crash log, I tried to file the bug.  I found that the
> first few lines of the crash log provided missing or even misleading information
> about where to file the bug:

Changed things so that you'll be told to file the bug against pirut.

Note You need to log in before you can comment on or make changes to this bug.