Bug 241923 - regressions in xchat
regressions in xchat
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 14:32 EDT by Matthias Clasen
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.8.2-8.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-07 12:00:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to disable the tray icon by default (556 bytes, patch)
2007-06-02 14:52 EDT, Kevin Kofler
no flags Details | Diff

  None (edit)
Description Matthias Clasen 2007-05-31 14:32:24 EDT
the new xchat in rawhide has 2 regressions:

1. the menu item is now a meaningless "X-Chat" rather than the somewhat cryptic,
   but informative "IRC" 

2. There is a meaningless X on the notification area now, for no good reason
Comment 1 Kevin Kofler 2007-06-02 14:11:08 EDT
1. is "fixed" (reverted) in xchat-2.8.2-7-fc[78].
2. is a new feature provided by upstream, some people love it, others hate it, 
but that's why it's an option.
Comment 2 Christopher Aillon 2007-06-02 14:35:27 EDT
(In reply to comment #1)
> 2. is a new feature provided by upstream, some people love it, others hate it, 
> but that's why it's an option.

It's the maintainer's job to integrate things well with Fedora.  If something is
useless to Fedora users then it shouldn't be there.  What exactly is the purpose
of the notification area icon?
Comment 3 Christopher Aillon 2007-06-02 14:36:36 EDT
Also, it's important to note that we also should be striving for good design. 
Putting icons that don't do anything is not good design.  We should in general
not be adding new icons to the notification area without a good reason to do so.
Comment 4 Kevin Kofler 2007-06-02 14:40:30 EDT
The purpose is notifying the user of incoming messages when he/she is looking 
at other windows than X-Chat. This is common for IM clients, so why is it so 
bad for IRC that we need to override the upstream default for this?

Now, I don't like notification area pollution either, and in fact I have this 
feature turned off myself, so I'm not principally opposed to flipping the 
default with a (hopefully one-line) patch. However, I think end users will 
wonder why Fedora's X-Chat "does not have" the feature upstream X-Chat 
advertises so loudly if it's disabled by default.
Comment 5 Kevin Kofler 2007-06-02 14:52:15 EDT
Created attachment 155991 [details]
Patch to disable the tray icon by default

This trivial one-character patch should be enough to change the default.

The real question is: are you SURE you want me to do this? :-)
Comment 6 Kevin Kofler 2007-06-02 15:26:03 EDT
Oh, and let's make sure Remi is aware of this discussion too.
Comment 7 Christopher Aillon 2007-06-02 16:05:33 EDT
What about libwnck?  Isn't that sufficient for notifying the user?
Comment 8 Kevin Kofler 2007-06-02 16:09:47 EDT
If that's what shows those "passive popups", that's actually a (non-default) 
option too ("Show tray balloon on: [ ] Channel message [ ] Private message [ ] 
Highlighted message") and can be set independently of the tray icon, however 
I'd argue that said form of notification is much more invasive than the small 
tray icon.
Comment 9 Christopher Aillon 2007-06-02 16:11:25 EDT
No, libwnck is what makes the taskbar item blink.
Comment 10 Kevin Kofler 2007-06-02 16:17:01 EDT
Oh, yes, that feature is enabled by default, if you think that's sufficient as 
the default, I'll apply the posted patch to disable the tray icon by default.

What the tray icon allows, though, is hiding the window and taskbar entry, 
actually taking up less space than the taskbar entry, and still getting 
notifications. But I don't know whether that's something a user (of the kind 
who doesn't go through all the configuration options at first startup 
anyway ;-) ) would be likely to want to do.
Comment 11 Christopher Aillon 2007-06-02 16:20:18 EDT
I agree with your assertion about the default setup, and yeah I do think it's
sufficient for most people.  People that want the icon can still enable it by
going through the prefs.
Comment 12 Christopher Aillon 2007-06-02 16:24:49 EDT
And something that might be worth pushing upstream is that the icon shouldn't be
present when xchat and the taskbar item is shown.  No need for two notifications.
Comment 13 Kevin Kofler 2007-06-02 16:26:07 EDT
The problem with that idea is that the interface to hide the main window goes 
through the tray icon.
Comment 14 Christopher Aillon 2007-06-02 16:29:30 EDT
Sounds more like a problem in the design/implementation, not the idea :-)
Comment 15 Kevin Kofler 2007-06-02 16:38:01 EDT
Currently building 2.8.2-8.fc[78] with this patch.
Comment 16 Kevin Kofler 2007-06-02 17:08:13 EDT
2.6.2-8 built for Rawhide and F7 candidate updates, submitted for F7 
updates-testing in Bodhi.

This now addresses the second point too (the first one was already addressed in 
2.6.2-7), so I'm closing this again.
Comment 17 Fedora Update System 2007-06-04 00:11:43 EDT
xchat-2.8.2-8.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Kevin Kofler 2007-06-04 03:19:21 EDT
Some notes: The packages without the patch (2.8.2-x, x<=7) were never pushed to 
F7 updates, only updates-testing, and I had them pulled.

If you already had 2.8.x (<=2.8.2-7) installed from testing or Rawhide and ran 
it at least once, the icon won't automatically disappear with the update, 
you'll have to turn it off in the preferences if you don't want it. But new 
installations and upgrades fom 2.6.x (which is what's still in F7) default to 
not showing the icon.
Comment 19 Fedora Update System 2007-06-07 11:59:56 EDT
xchat-2.8.2-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Rudolf Kastl 2007-06-13 08:19:04 EDT
actually regarding the tray notification in my eyes it makes perfect sense
because it behaves exactly like e.g. gaim does.

why is it less meaningful than the gaim message notification? personally i do
like the feature and i dont feel like having the tray polluted by this.

xchat-gnome e.g. has a notification turned on by default aswell. why is xchat
special here and has to have this feature turned off?
Comment 21 Kevin Kofler 2007-06-13 08:23:18 EDT
Well, we can't please everyone. :-)

FYI, I don't care either way, I just implemented what the primary maintainer 
wanted me to, so I'll let Christopher Aillon and Matthias Clasen continue this 
discussion with you if they're willing to discuss this. If the consensus is to 
enable it by default after all, it's easy to change it back.

Note You need to log in before you can comment on or make changes to this bug.