Bug 241931 - yum provides comman doesn't return any results
Summary: yum provides comman doesn't return any results
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-31 19:15 UTC by Dawid Zamirski
Modified: 2014-01-21 22:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-31 19:26:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dawid Zamirski 2007-05-31 19:15:12 UTC
When querying for any file with yum provides <file_name> the result is No
Matches found

How reproducible:
always

Steps to Reproduce:
1. yum install yum-presto
2. rpm -ql yum-presto - you'll see presto.conf in /etc/yum/plugins.d
3. yum provides presto.conf
4. No Matches found
  
This was tested with yum-3.2.0-1.fc7

Comment 1 Seth Vidal 2007-05-31 19:26:20 UTC
presto.conf doesn't exist in the package as a provide

/etc/yum/plugins.d/presto.conf DOES exist as a provide, though.

yum provides /etc/yum/plugins.d/presto.conf
or
yum provides \*presto.conf

if that doesn't work then it's a bug, please re-open it. Otherwise I'm closing
it as not a bug.


Comment 2 Dawid Zamirski 2007-05-31 19:56:58 UTC
Ok, I understand now but it's a little confusing from the end-user stand point.
Would it be reasonable to implement so that yum provides presto.conf would still
return a result but mark it somehow (in color?) to indicate that the package
itself doesn't contain it?



Note You need to log in before you can comment on or make changes to this bug.