Bug 241934 - Can't connect to secure wireless networks
Can't connect to secure wireless networks
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 16:02 EDT by Steven Garrity
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.6.22.1-27.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 15:51:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages entry for ipw2100 failure to connect to wpa secured network (7.94 KB, text/plain)
2007-06-05 03:19 EDT, Stuart Martin
no flags Details

  None (edit)
Description Steven Garrity 2007-05-31 16:02:33 EDT
Description of problem:
Just installed Fedora 7 on a ThinkPad T60 with the IPW3945 wireless card.

I've turned on NetworkManager, and can connect to open (unsecure networks) after
booting, but trying to connect to any secure networks fails (networks I was able
to connect to with FC6 this morning.

Also after trying to connect to a secure network, I can no longer connect to
even the open network I can connect to after booting.

Not sure what info will help - just ask and I'll do my best to provide it.
Comment 1 Matt Dinsmore 2007-05-31 17:05:03 EDT
I get this too, on a T40 with ipw2100.

I am thinking the big error is this : May 31 16:57:51 nitrogen
wpa_supplicant[8208]: Association request to the driver failed

This was working with FC6 fine.

Here are some logs : 

May 31 16:57:43 nitrogen NetworkManager: <info>  User Switch:
/org/freedesktop/NetworkManager/Devices/eth1 / NETWORK
May 31 16:57:43 nitrogen NetworkManager: <info>  Deactivating device eth1. 
May 31 16:57:43 nitrogen avahi-daemon[2169]: Withdrawing address record for
fe80::20c:f1ff:fe0d:1d8a on eth1.
May 31 16:57:43 nitrogen avahi-daemon[2169]: Leaving mDNS multicast group on
interface eth1.IPv6 with address fe80::20c:f1ff:fe0d:1d8a.
May 31 16:57:43 nitrogen avahi-daemon[2169]: Interface eth1.IPv6 no longer
relevant for mDNS.
May 31 16:57:43 nitrogen dhcdbd: message_handler: message handler not found
under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.reason
May 31 16:57:43 nitrogen NetworkManager: <info>  Device eth1 activation
scheduled... 
May 31 16:57:43 nitrogen NetworkManager: <info>  Deactivating device eth0. 
May 31 16:57:43 nitrogen dhclient: DHCPRELEASE on eth0 to 10.1.1.1 port 67
May 31 16:57:44 nitrogen kernel: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
May 31 16:57:44 nitrogen avahi-daemon[2169]: Withdrawing address record for
10.1.3.249 on eth0.
May 31 16:57:44 nitrogen avahi-daemon[2169]: Leaving mDNS multicast group on
interface eth0.IPv4 with address 10.1.3.249.
May 31 16:57:44 nitrogen avahi-daemon[2169]: Interface eth0.IPv4 no longer
relevant for mDNS.
May 31 16:57:44 nitrogen avahi-daemon[2169]: Withdrawing address record for
fe80::20d:60ff:fe8d:6a90 on eth0.
May 31 16:57:44 nitrogen avahi-daemon[2169]: Leaving mDNS multicast group on
interface eth0.IPv6 with address fe80::20d:60ff:fe8d:6a90.
May 31 16:57:44 nitrogen avahi-daemon[2169]: Interface eth0.IPv6 no longer
relevant for mDNS.
May 31 16:57:44 nitrogen NetworkManager: <info>  Activation (eth1) started... 
May 31 16:57:44 nitrogen NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) scheduled... 
May 31 16:57:44 nitrogen NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) started... 
May 31 16:57:44 nitrogen NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) scheduled... 
May 31 16:57:44 nitrogen NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) complete. 
May 31 16:57:44 nitrogen NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) starting... 
May 31 16:57:44 nitrogen NetworkManager: <info>  Activation (eth1/wireless):
access point 'NETWORK' is encrypted, but NO valid key exists.  New key needed. 
May 31 16:57:44 nitrogen NetworkManager: <info>  Activation (eth1) New wireless
user key requested for network 'NETWORK'. 
May 31 16:57:44 nitrogen NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) complete. 
May 31 16:57:46 nitrogen avahi-daemon[2169]: Joining mDNS multicast group on
interface eth1.IPv6 with address fe80::20c:f1ff:fe0d:1d8a.
May 31 16:57:46 nitrogen avahi-daemon[2169]: New relevant interface eth1.IPv6
for mDNS.
May 31 16:57:46 nitrogen avahi-daemon[2169]: Registering new address record for
fe80::20c:f1ff:fe0d:1d8a on eth1.*.
May 31 16:57:46 nitrogen ntpd[1882]: sendto(61.129.66.79) (fd=22): Invalid argument
May 31 16:57:51 nitrogen NetworkManager: <info>  Activation (eth1) New wireless
user key for network 'NETWORK' received. 
May 31 16:57:51 nitrogen NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) scheduled... 
May 31 16:57:51 nitrogen NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) started... 
May 31 16:57:51 nitrogen NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) scheduled... 
May 31 16:57:51 nitrogen NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) complete. 
May 31 16:57:51 nitrogen NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) starting... 
May 31 16:57:51 nitrogen NetworkManager: <info>  Activation (eth1/wireless):
access point 'NETWORK' is encrypted, and a key exists.  No new key needed. 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: sending command
'INTERFACE_ADD eth1		wext	/var/run/wpa_supplicant	' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: response was 'OK' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: sending command 'AP_SCAN 1' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: response was 'OK' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: sending command 'ADD_NETWORK' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: response was '0' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 ssid 43454e54524958' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: response was 'OK' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 proto WPA' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: response was 'OK' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 key_mgmt WPA-PSK' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: response was 'OK' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 psk <key>' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: response was 'OK' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: sending command
'ENABLE_NETWORK 0' 
May 31 16:57:51 nitrogen NetworkManager: <info>  SUP: response was 'OK' 
May 31 16:57:51 nitrogen NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) complete. 
May 31 16:57:51 nitrogen wpa_supplicant[8208]: Trying to associate with
00:0d:0b:e8:d1:84 (SSID='NETWORK' freq=2412 MHz) 
May 31 16:57:51 nitrogen wpa_supplicant[8208]: Association request to the driver
failed 
May 31 16:57:51 nitrogen wpa_supplicant[8208]: CTRL-EVENT-DISCONNECTED -
Disconnect event - remove keys 
May 31 16:57:56 nitrogen ntpd[1882]: Deleting interface #5 eth0,
fe80::20d:60ff:fe8d:6a90#123, interface stats: received=0, sent=0, dropped=0,
active_time=2400 secs
May 31 16:57:56 nitrogen ntpd[1882]: Deleting interface #6 eth0, 10.1.3.249#123,
interface stats: received=100, sent=113, dropped=1, active_time=2400 secs
May 31 16:57:59 nitrogen NetworkManager: <info>  Activation (eth1/wireless):
disconnected during association, asking for new key. 
May 31 16:57:59 nitrogen NetworkManager: <info>  Activation (eth1) New wireless
user key requested for network 'NETWORK'. 
May 31 16:58:04 nitrogen NetworkManager: <info>  Activation (eth1) New wireless
user key request for network 'NETWORK' was canceled. 
May 31 16:58:04 nitrogen NetworkManager: <info>  Activation (eth1) failure
scheduled... 
May 31 16:58:04 nitrogen NetworkManager: <info>  Activation (eth1) failed for
access point (NETWORK) 
May 31 16:58:04 nitrogen NetworkManager: <info>  Activation (eth1) failed. 
May 31 16:58:04 nitrogen NetworkManager: <info>  Deactivating device eth1. 
May 31 16:58:04 nitrogen wpa_supplicant[8208]: CTRL-EVENT-TERMINATING - signal
15 received 
May 31 16:58:04 nitrogen avahi-daemon[2169]: Withdrawing address record for
fe80::20c:f1ff:fe0d:1d8a on eth1.
May 31 16:58:04 nitrogen avahi-daemon[2169]: Leaving mDNS multicast group on
interface eth1.IPv6 with address fe80::20c:f1ff:fe0d:1d8a.
May 31 16:58:04 nitrogen avahi-daemon[2169]: Interface eth1.IPv6 no longer
relevant for mDNS.
May 31 16:58:04 nitrogen NetworkManager: <info>  SWITCH: no current connection,
found better connection 'eth0'. 
May 31 16:58:04 nitrogen NetworkManager: <info>  Will activate connection 'eth0'. 
May 31 16:58:04 nitrogen NetworkManager: <info>  Device eth0 activation
scheduled... 
Comment 2 Matt Dinsmore 2007-05-31 20:25:03 EDT
Also getting this from dmesg, not sure if it's related, but it's during the NIC
startup phase...

e1000: eth0: e1000_watchdog: NIC Link is Up 1000 Mbps Full Duplex, Flow Control:
RX/TX
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)
 [<c042b0cf>] local_bh_enable+0x45/0x92
 [<c06002bd>] cond_resched_softirq+0x2c/0x42
 [<c059adf3>] release_sock+0x4f/0x9d
 [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
 [<c059adb6>] release_sock+0x12/0x9d
 [<c05c7755>] tcp_recvmsg+0x8d2/0x9de
 [<c04808dc>] core_sys_select+0x218/0x2f3
 [<c05dec95>] inet_sendmsg+0x3b/0x45
 [<c0598731>] sock_aio_write+0xf6/0x102
 [<c045da36>] get_page_from_freelist+0x23b/0x2a5
 [<c04754ee>] do_sync_write+0xc7/0x10a
 [<c0436e71>] autoremove_wake_function+0x0/0x35
 [<c0475d47>] vfs_write+0xbc/0x154
 [<c0476342>] sys_write+0x41/0x67
 [<c0404f70>] syscall_call+0x7/0xb
 =======================
eth1: no IPv6 routers present
eth0: no IPv6 routers present
Comment 3 Matt Dinsmore 2007-06-01 09:17:00 EDT
Not using selinux, btw
Comment 4 Herward Hoyer 2007-06-01 18:23:36 EDT
IBM Thinkpad T40, same bug, same backtrace.

Also interesting maybe:
Jun  2 00:01:55 localhost wpa_supplicant[2796]: Trying to associate with
00:0f:66:56:e0:cd (SSID='deadbeef' freq=2437 MHz)
Jun  2 00:01:56 localhost wpa_supplicant[2796]: Association request to the
driver failed
Jun  2 00:01:56 localhost kernel: ipw2100: exit - failed to send CARD_DISABLE
command
Jun  2 00:01:56 localhost kernel: ipw2100: exit - failed to send CARD_DISABLE
command
Jun  2 00:01:56 localhost kernel: ipw2100: Fatal interrupt. Scheduling firmware
restart.
Jun  2 00:01:56 localhost kernel: ipw2100: Fatal interrupt. Scheduling firmware
restart.
Jun  2 00:01:58 localhost kernel: ipw2100: exit - failed to send CARD_DISABLE
command
Comment 5 Herward Hoyer 2007-06-01 18:50:41 EDT
compiling and installing ipw2100.ko from ipw2100-1.2.2.tgz fixed the problems. 
Comment 6 Stuart Martin 2007-06-05 02:57:38 EDT
I've had the exact same problem connecting to my WPA-Personal network on a IBM
ThinkPad T41 using the ipw2100 wireless adapter.

The simple fix for me was to just re-enable ipv6 on the interface. As soon as I
did this, it immediately worked on the next connection using NetworkManager.
I didn't have this problem in FC6 using the same 1.3 firmware, must be a bug in
the F7 driver.

I haven't tried this fix on the live cd but it had the same problem by default.

Hope this helps, Stoo
Comment 7 Stuart Martin 2007-06-05 03:19:44 EDT
Created attachment 156180 [details]
/var/log/messages entry for ipw2100 failure to connect to wpa secured network

Sorry about the previous post, I jumped the gun in my excitement for thinking I
fixed the problem so easily.

What happened is after making the change to ipv6, the gnome keyring asked me to
create a password, something I was never able to get to previously. Appearently
it just fell back to some neighbor's open wireless network.

So still having the same issue, here's my log.
Comment 8 Stuart Martin 2007-06-05 04:00:06 EDT
Thanks Herward! Compiling and installing the ipw2100.ko fixed it for me as well.
Comment 9 John W. Linville 2007-06-05 07:47:06 EDT
Odd...perhaps Intel has neglected to send a patch upstream?  I'll check into 
it.
Comment 10 Harald Hoyer 2007-06-05 08:25:55 EDT
you may also check the http://ieee80211.sourceforge.net/ header files and please
include them in kernel-devel
Comment 11 John W. Linville 2007-06-05 08:32:32 EDT
Why would I do that?
Comment 12 John W. Linville 2007-07-30 15:33:11 EDT
Is this still a problem w/ current F7 kernels?
Comment 13 Steven Garrity 2007-07-30 15:38:58 EDT
Seems to be working with the .22 kernel updates. I think we can mark this as fixed?

Note You need to log in before you can comment on or make changes to this bug.