Bug 241935 - [VMWARE] No available hard drives when booting from boot.iso or live cd
[VMWARE] No available hard drives when booting from boot.iso or live cd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 16:04 EDT by Troy Holder
Modified: 2007-11-30 17:12 EST (History)
7 users (show)

See Also:
Fixed In Version: 2.6.22.7-85.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 18:34:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Troy Holder 2007-05-31 16:04:53 EDT
Description of problem:

Booting from either the live cd or the boot.iso from the i386, no hard drives
are found. This has been tried on a Dell Workstation with the ICH5 chipset and
in Vmware Server.

Version-Release number of selected component (if applicable):

Fedora 7

How reproducible:

Every time

Steps to Reproduce:
1. Boot from media
2. Choose to install
3. No hard drives available to install to
  
Actual results:
No hard drives listed

Expected results:
See the hard drives as available to be installed to.

Additional info:
Comment 1 Troy Holder 2007-05-31 16:05:29 EDT
Worked in the last Release Candidate.
Comment 2 Sven Neuhaus 2007-06-01 03:30:32 EDT
I have a similar problem, the kernel times out during some ATA operations on my
MSI P965 Neo mainboard and gives up after a while disabling the ATA port.
Using the kernel option "noirqdebug" solved this problem for me.

The mainboard has an Intel 965 chipset and disabling the jmicron controller in
the BIOS doesn't solve the problem.
Comment 3 Troy Holder 2007-06-01 14:36:06 EDT
Adding that kernel option had no effect in vmware server.
Comment 4 Brian Black 2007-06-01 22:53:17 EDT
Very similar problem.  I have an Abit KR7A-Raid with a Highpoint raid controller
on the motherboard.  When the PATA HDD is attached to the raid it is not seen,
when moved the the regular IDE it is found.
Comment 5 Andre Robatino 2007-06-02 09:12:03 EDT
  This looks like a dupe of bug #230849.
Comment 6 Sven Neuhaus 2007-06-04 08:56:30 EDT
I guess I am seeing a different bug with my Intel-965-IDE board then, I'll file
a separate bug tonight.
Comment 7 Alan Cox 2007-06-05 13:57:26 EDT
Can we keep to one bug per bugzilla

Sven - please file a bug, include info on the devices attached to the problem
channel

Brian - likewise. I've got a couple of reports that seem to be anaconda loading
the wrong module so it may be that but its a different bug.

Comment 8 Yan Li 2007-08-14 23:26:52 EDT
Might be a similar problem: I tried to install F7 DVD on a VMware Server v
1.0.3.  Used default config of "Other Linux 2.6", which included a 8.0 GB SCSI
Virtual HD.  The installer could NOT find any HD on it and I just could not install.

The underlying real machine is a new IBM ThinkCentre, with Intel 82801HB(ICH8)
SATA AHCI Controller, running RHEL5 x86-64 with all latest updates.
Comment 9 Alan Cox 2007-09-10 11:12:54 EDT
Setting the vmware case severity to low. Really vmware need to look at this not
us as it seems to be an emulation/vmware configuration issue.

The non vmware ones should now all be seperate bugs and are obviously important
and will be (and arebeing) worked on
Comment 10 Yan Li 2007-09-10 21:07:33 EDT
I can hardly agree this to be a low priority one, but I think it's a
show-stopper. Image there're a bunch of newbies who wanna give Fedora a try in
their VMware, but just lost in despair, can't figure out how to install it
because Fedora can't find their default virtual HD!

No matter the wrong is at VMware side or at ours, we can't just let the
installation fail in VMware in the wild.
Comment 11 Chuck Ebbert 2007-09-14 15:05:12 EDT
Fix in  kernel-2.6.22.6-81.fc7, submitted for testing.

(We really shouldn't have to fix vmware's bugs -- this workaround may be removed
in some future release.)

Note You need to log in before you can comment on or make changes to this bug.