Bug 241937 - Feature request: display dependency chain in anaconda
Feature request: display dependency chain in anaconda
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 16:20 EDT by Ronny Fischer
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 13:52:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronny Fischer 2007-05-31 16:20:36 EDT
Description of problem:
Feature Request:

Anaconda is unable to display dependencies when installing Fedora with custom 
checked or unchecked packages. This would be very helpful. I would like to see 
something like the Mandriva installer displays what packages are needed/erased 
in case of checking/unchecking packages at the installation.

Version-Release number of selected component (if applicable):
Anacondo (no specific version)

How reproducible:
always

Steps to Reproduce:
1. install a custom Fedora with anaconda
2.
3.
  
Actual results:
unchecked packages appear because of dependencies

Expected results:
when unchecking packages at the installation display a message of what packages 
will be affected to be erased in this case

Additional info:

I believe the installer of Mandriva Linux shows messages of what packages will 
be erased when removing a package from the standard installation. Something 
like this would be great.
Comment 1 Sukru TIKVES 2007-05-31 18:09:03 EDT
Even a simple (flat) list would suffice, yes this feature would be really nice 
to have.
Comment 2 Jeremy Katz 2007-06-04 13:52:53 EDT
Computing this on the fly (which is required, given the fact that you can add
repos including updates, etc) is extremely expensive and would introduce a lot
of lag.  Not to mention it's terrible UI design.
Comment 3 Sukru TIKVES 2007-06-04 14:18:38 EDT
Ok, I'm really shocked to see WONT_FIX for a small feature request this soon, 
but I cannot say it was not expected (I guess that's the general attitude here).

However I do not believe that the above reasons are enough to justify that 
resolution.

First of all, even if the option would be "slow", you could always make 
it "optional" (i.e: shown only when requested by clicking a button).

Additionally, YUM already needs to build this information, anyway. (It will 
install those dependencies, right?) I know, because command line YUM already 
does that (e.g: Installing 10 new packages [y/N]: ). Pirut that that too. It 
shall not be that difficult to display a list of strings on the screen 
organized as a tree via GTK+ (yet I'm no GTK+ programmer)

Finally, several other distributions already does that. So we know it can be 
done.

Please reopen the bug as LOW / CONFIRMED or similar, so that someone with 
enough time could implemented it.

Note You need to log in before you can comment on or make changes to this bug.