Bug 241938 - sfdisk program missing in anaconda /usr/sbin directory
Summary: sfdisk program missing in anaconda /usr/sbin directory
Status: CLOSED DUPLICATE of bug 224297
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
medium
Target Milestone: ---
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-31 20:21 UTC by Marc Curry
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-31 20:38:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc Curry 2007-05-31 20:21:52 UTC
Description of problem:

sfdisk has disappeared from anaconda's /usr/sbin directory, so many different
types of partitions that could formerly (RHEL4) be made in a %pre section of a
kickstart configuration file (e.g. logical, 8e (LVM), fd (RAID), etc...
partitions) can no longer be created.  The fdisk and parted tools are there, but
parted (version GNU 1.8.1) does not support partitions of any type other than
primary and extended, and fdisk is interactive-only (can't use in kickstart).

Version-Release number of selected component (if applicable):

anaconda 11.1.2-36-1

How reproducible:

Every time.

Steps to Reproduce:
1. Try to create a partition of type 8e in kickstart %pre section using sfdisk.
  
Actual results:

Command not found.

Expected results:

Command found!  (It was there in RHEL4)

Additional info:

Comment 1 David Cantrell 2007-05-31 20:38:45 UTC

*** This bug has been marked as a duplicate of 224297 ***


Note You need to log in before you can comment on or make changes to this bug.