This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 241939 - intel driver has blinky startup
intel driver has blinky startup
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 16:33 EDT by Ronny Fischer
Modified: 2008-01-14 05:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 05:17:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/Xorg.o.log (39.59 KB, text/plain)
2007-06-01 02:27 EDT, Ronny Fischer
no flags Details
Tim Behrsin's Xorg log (52.27 KB, text/plain)
2007-06-04 16:39 EDT, Tim Behrsin
no flags Details

  None (edit)
Description Ronny Fischer 2007-05-31 16:33:07 EDT
Description of problem:
When using the "intel" graphics driver on Intel 915GM the Xserver is always 
starting twice before displaying the graphical environment.

Version-Release number of selected component (if applicable):
Fedora 7 Kernel 2.6.21

How reproducible:
always

Steps to Reproduce:
1. install Fedora 7 on a system with Intel 915 integrated graphics card 
2.
3.
  
Actual results:
when starting xorg, the display shortly turns off and on again two times before 
loading a graphical screen

Expected results:
X should started with such issue 

Additional info:
Using "i810" instead of "intel" resolves the problem but system-config-display 
shows an "unknown video card"
Comment 1 Jarod Wilson 2007-05-31 23:16:11 EDT
Not a kernel bug, changing to correct component. But also likely NOTABUG, just a difference in the driver. 
Works great for me, anyhow. :)

I'd suggest attaching your /var/log/Xorg.0.log file when using the intel driver just the same.
Comment 2 Ronny Fischer 2007-06-01 02:27:40 EDT
Created attachment 155857 [details]
/var/log/Xorg.o.log
Comment 3 Ronny Fischer 2007-06-01 02:29:20 EDT
Seems to be nothing wrong with the Xorg.0.log. I also noticed difficulties 
using compiz together with the "intel" driver.
Comment 4 Tim Behrsin 2007-06-04 16:39:40 EDT
Created attachment 156129 [details]
Tim Behrsin's Xorg log

I see the same behaviour as described.... although I don't think it is loading
two X sessions: I think it is just a problem with bringing the display up.

Sequence of events whenever an X display is loaded using the intel driver:
( 1. text mode )
2. lcd off
3. blank screen
4. lcd off
5. blank screen
6. normal (mouse pointer, etc)

I'm on a Dell Inspiron 9400 with a 945GM. This happens with rhgb, gdm, etc.
Comment 5 Tim Behrsin 2007-06-04 16:43:18 EDT
I would also like to say that although this is an annoyance for me rather than a
bug. Compiz, 3D games work fine for me - in fact the Intel driver is a great
improvement over i810 in every respect :)
Comment 6 MartinG 2007-06-11 20:27:07 EDT
Same happens for me: Dell Latitude X1

lspci:
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML 
Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express 
Graphics Controller (rev 03)

Could it have something to do with this line in Xorg.0.log?:
(WW) intel: No matching Device section for instance (BusID PCI:0:2:1) found

This also happens when one switch between to X sessions (ie. Ctrl-Alt-F8 and 
back with Ctrl-Alt-F7) - really annoying, as it takes a couple of extra seconds 
to switch.
Comment 7 Jesse Barnes 2008-01-10 17:41:33 EST
Yeah, this is an annoying bug.  I actually have some fixes for this, but 
they're not upstream yet, and probably won't be until 2.3 at the earliest.

Anyway, this is really an RFE since everything should still work, just not as 
prettily as it should.
Comment 8 Matěj Cepl 2008-01-14 05:17:28 EST
Given that this is really low-priority with F7, and should be fixed upstream
anyway, closing this bug as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.