Bug 24195 - Kudzu prompts to remove "unknown" on first boot
Kudzu prompts to remove "unknown" on first boot
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-01-16 23:50 EST by Chris Adams
Modified: 2014-03-16 22:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-09 23:58:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/etc/sysconfig/hwconf with "unknown" devices (2.70 KB, text/plain)
2001-01-16 23:51 EST, Chris Adams
no flags Details

  None (edit)
Description Chris Adams 2001-01-16 23:50:25 EST
After installing, on the first boot kudzu came up said that a device was
removed and listed it as "unkown".  The only things in
/etc/sysconfig/hwconf that have a description of "unknown" are the USB root
hub and an unknown USB device (probably my monitor; I have a ViewSonic
PT775 with a built in USB hub - with Windows software you can also make all
the display adjustments via USB that you can also make from the buttons on
the monitor).

I've attached the hwconf file.
Comment 1 Chris Adams 2001-01-16 23:51:15 EST
Created attachment 7728 [details]
/etc/sysconfig/hwconf with "unknown" devices
Comment 2 Bill Nottingham 2001-01-16 23:54:52 EST
I am fairly sure this is fixed in the current rawhide kudzu package - can
you try that and reopen if it persists?
Comment 3 Chris Adams 2001-01-17 00:31:05 EST
I tried the latest kudzu from ftp.beta.redhat.com/pub/rawhide, and I got the
same result.  When I allowed it to remove the configuration, it removed the
config for the last device in my hwconf (which I think is the USB monitor
Comment 4 Bill Nottingham 2001-02-01 16:55:09 EST
This really should be fixed as of 0.92-1. I hope. ;)
Comment 5 Bill Nottingham 2001-02-09 21:17:50 EST
Apparently not solved. Ugh.

*** This bug has been marked as a duplicate of 26906 ***
Comment 6 Chris Adams 2001-02-09 23:10:37 EST
This isn't really a duplicate of bug 26906.  That bug is about "unknown" devices
showing up.

My problem is that an "unknown" device disappears between install and the first
boot.  The installer finds one, but upon the first boot, it is gone, and I get
the kudzu prompt asking if I want to remove the configuration for the "unknown"
device that is gone.

This does still happen with beta3
Comment 7 Bill Nottingham 2001-02-09 23:23:54 EST
Does it ever show up again on subsequent boots, or is it gone forever?

If you look in /proc/bus/usb/devices, does it appear there as well?
Comment 8 Bill Nottingham 2001-02-09 23:46:32 EST
Out of curiousity (I doubt this matters) was this a text or GUI install?
Comment 9 Chris Adams 2001-02-09 23:58:10 EST
This was a GUI install (straight up normal install - nothing extra at
the boot prompt since "expert" crashes on me, already Bugzillaed).

This may be something about the device or USB hardware.  I believe the
"unknown" device that comes and goes is my monitor.  This is a later
model ViewSonic PT775, with a 4 port USB hub built-in to the base.  The
monitor itself is a 5th port; you can control the monitor (horiz/vert
size/pos, pincusion, etc. like the on-screen controls via front panel
buttons) via a Windows program over USB.

If I "cat /proc/bus/usb/devices", the hub is there but not the monitor
device.  If I power cycle the monitor (I have to leave it off for
several seconds - if I turn it off for just a second and turn it back
on, the hub is gone), the monitor device re-appears.  If I then run
kudzu, it re-finds the "unknown" device.

Here is the info for this device from /proc/bus/usb/devices (is there
any tool to parse this info out?):

T:  Bus=01 Lev=02 Prnt=04 Port=00 Cnt=01 Dev#=  5 Spd=12  MxCh= 0
D:  Ver= 1.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0611 ProdID=0000 Rev= 0.00
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=(none)
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms

Anyway, this is probably not a Red Hat problem.  Sorry for the false
Comment 10 Bill Nottingham 2001-02-12 17:49:08 EST
OK. If the device disappears from the /proc entry, there's very little
kudzu can do about finding it again.

Note You need to log in before you can comment on or make changes to this bug.