Bug 241968 - cannot create wireless connection using 'Network Device Control' utility using iwl3945 driver and wlan0
cannot create wireless connection using 'Network Device Control' utility usin...
Status: CLOSED DUPLICATE of bug 241507
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 19:52 EDT by Keith Outwater
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-10 07:54:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of 'dmesg' (30.87 KB, text/plain)
2007-05-31 19:52 EDT, Keith Outwater
no flags Details

  None (edit)
Description Keith Outwater 2007-05-31 19:52:22 EDT
Description of problem:
No ability to create wlan0 device using 'menu->system->network device control'
when using iwl3945 wifi driver.


Version-Release number of selected component (if applicable):
Fedora Core 7 with all updates

How reproducible:
always


Steps to Reproduce:
1. Use menu->system->netwlrk device control
2.Hit 'configure' button
3.In 'network configuration' dialog hit 'new'
4. Select 'wireless connection'

The only option available is 'Other Wireless Card'

Output of /sbin/lsmod | grep iwl3945 :
iwl3945               154405  0
mac80211              153925  2 rc80211_simple,iwl3945

I have attached output of 'dmesg'


  
Actual results:
No ability to create network connection using wlan0 and iwl3945


Expected results:
Ability to create a wireless connection using iwl3945 device

Additional info:
wmaster0 shows up as a device.  Trying to activate it results in a long delay
followed by a timeout.
Comment 1 Keith Outwater 2007-05-31 19:52:22 EDT
Created attachment 155853 [details]
Output of 'dmesg'
Comment 2 Hans de Goede 2007-06-10 07:54:20 EDT
This is not a network-manager problem, the iwl3945 in the F-7 kernel has known
troubles working with wpa.

There is an F7 kernel-update candidate available here:
http://people.redhat.com/davej/kernels/Fedora/fc7/RPMS.kernel/

Which amongst other things contains various fixes to the iwl3945 driver. Please
try this kernel and report back how it works for you.

Always be carefull when testing new kernels. Use rpm -ivh to install the new
kernel besides your current one so that you can always boot back into the old
kernel.

---

Also this problem has already been reported as bug 241507 , closing as a
duplicate of that bug.


*** This bug has been marked as a duplicate of 241507 ***

Note You need to log in before you can comment on or make changes to this bug.