Bug 241986 - Kernel panic: Frysk causes fatal exception in interrupt
Kernel panic: Frysk causes fatal exception in interrupt
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 23:19 EDT by Kris Van Hees
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 16:31:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kris Van Hees 2007-05-31 23:19:04 EDT
Description of problem:
    During the execution of the frysk testsuite, a kernel oops was triggered,
    causing the entire box to hang.  I chose severity high because this problem
    causes a total crash of the box, kernel panic without syncing.

Version-Release number of selected component (if applicable):


How reproducible:
    Reproducing this problem has been difficult at best.  It occurs every now
    and then, with no real indication of frequency due to it not having been
    triggered more than once every 2-3 weeks.

Steps to Reproduce:
1. Run frysk testsuite (using make -k check)
2. If problem does not occur, repeat step 1 (sometimes MANY times)
  
Actual results:
IP is at 0x0
eax: c475efa0   ebx: 00000000   ecx: f7e5eb80   edx: c475efa0
esi: c2402380   edi: 00000002   ebp: 00000000   esp: c077afc8
ds: 007b   es: 007b   ss: 0068
Process funit-child (pid: 30778, ti=c077a000 task=f7e06630 task.ti=e9e24000)
Stack: c04316e7 c24023fc 00000000 00000008 c043176b c04276d4 00000001
c072bb28
      c042762c e9e24f8c e9e24000 00000046 bfa29b00 c04067d7
Call Trace:
[<c04316e7>] __rcu_process_callbacks+0xf2/0x15a
[<c043176b>] rcu_process_callbacks+0x1c/0x38
[<c04276d4>] tasklet_action+0x4b/0xa4
[<c042762c>] __do_softirq+0x5d/0xba
[<c04067d7>] do_softirq+0x59/0xb1
[<c0415cf0>] smp_apic_timer_interrupt+0x74/0x80
[<c0405018>] apic_timer_interrupt+0x28/0x30
=======================
Code:  Bad EIP value.
EIP: [<00000000>] 0x0 SS:ESP 0068:c077afc8
<0>Kernel panic - not syncing: Fatal exception in interrupt

Expected results:
    Successful completion of the frysk testsuite, without kernel panic.

Additional info:
    This problem has been extremely difficult to reproduce (so far).  It is not
    at all certain that Frysk has anything to do with the problem, nor is it
    certain that anything used by Frysk (e.g. utrace) can be blamed.  It is
    however a strict fact that this problem has only occurred so far during or
    shortly after running the Frysk test suite.
Comment 1 Chuck Ebbert 2007-06-01 10:52:06 EDT
The panic output is incomplete and doesn't include the kernel version.
Comment 2 Kris Van Hees 2007-06-01 10:58:40 EDT
The panic output in this bug report is all that could be obtained from the
remote console.

uname -a output:

Linux ca-tools2 2.6.20-1.2948.fc6 #1 SMP Fri Apr 27 18:53:15 EDT 2007 i686 i686
i386 GNU/Linux
Comment 3 Chuck Ebbert 2007-06-20 17:36:28 EDT
Kernel 2962 contains a utrace update.
Comment 4 Roland McGrath 2007-09-04 16:31:07 EDT
That's a failure mode of old utrace bugs fixed a while ago.  Reopen if it reoccurs.

Note You need to log in before you can comment on or make changes to this bug.