Bug 242 - SecureServer 2.0 - Serious Bug in logging
SecureServer 2.0 - Serious Bug in logging
Status: CLOSED CURRENTRELEASE
Product: Red Hat Secure Web Server
Classification: Retired
Component: secureweb (Show other bugs)
2.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Preston Brown
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-30 17:35 EST by seifried
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-07 15:24:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description seifried 1998-11-30 17:35:02 EST
There is a severe bug in SecureServer 2.0. Logging of user
access
to the site improperly processes control characters. The
bug is 100%
reproducable.

Situation leading to discover:

https://www.seifried.org/ - running RedHat 5.2 (with
standard
patches/etc), and RedHat Secure Server 2.0. I had setup a
directory
with htaccess requiring users to log in (using email as
their username and
a6 digit password). All was working fine, I tested it using
MSIE 4.01,
MSIE 5.0, and Netscape 4.07 on another RedHat 5.2 machine.
I then got a
few other people to test it, and strangely one person could
not log in. So
I tried his username/password combo, worked fine for me. He
was running
slackware and netscape 3.something, after checking the log
files I saw:

-----
charon.ipal.com - phil@rigel.ipal.net
 [29/Nov/1998:18:52:38 -0700] "GET /redhat-5.x/ HTTP/1.0"
401 473
----

Note that the line is split, this is not due to line wrap
or anything, as
we also have good entries like:

----
c60586-a.ptbrg1.sfba.home.com - schr@home.com
[29/Nov/1998:23:08:51 -0700]
"GET /redhat-5.x/package-listing/sendmail-doc-8.8.7-
20.i386.rpm.html HTTP/1.0"
200 721
----

which was one line but pine broke it up. It seems that
netscape 3.X sends
an extra "\n" after the username/etc which should be valid,
but apache
interpets it literally, and in addition to the pops it into
the log file,
which can result in spoofed entries and all other sorts of
bad things. I
believe this was a problem in Apache 1.2, but was fixed,
and I guess
reintroduced, so could you please refix it? =) Apart from
that I really
like SecureServer 2.0 (plus a glitch or two in some of the
utils like
dbmmanage, but c'est la vie).

-seifried, MCSE
Comment 1 David Lawrence 1998-12-07 15:09:59 EST
This has been assigned to a developer for further review.
Comment 2 Preston Brown 1998-12-07 15:24:59 EST
I suggest that you use the LogFormat / CustomLog directives to address
this problem in the short term.  In the long term, we will soon be
releasing an update of Secure Web Server which will be based on Apache
1.3.3 (you currently have a version based on Apache 1.3.1).

Note You need to log in before you can comment on or make changes to this bug.