This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 242002 - Remove dependency on /usr/sbin/sendmail
Remove dependency on /usr/sbin/sendmail
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 04:05 EDT by Jordan Russell
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-01 10:03:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jordan Russell 2007-06-01 04:05:21 EDT
Description of problem:
Please consider removing the

Requires:    /usr/sbin/sendmail

line from mdadm's RPM spec file.

Lots of packages are capable of sending mail, but mdadm is unusual in that it
actually has a dependency on /usr/sbin/sendmail.

I don't have an RPM-based MTA installed; I use a custom-built version of
Postfix. Because of the /usr/sbin/sendmail dependency, whenever a new mdadm
package comes out, I have to go in and manually install it with --nodeps. This
gets old after a while; I'd rather be able to keep it up to date with "yum" like
I do with every other package.


Version-Release number of selected component (if applicable):
mdadm-2.6.1-4.fc7 (and earlier versions, going back many years)
Comment 1 Doug Ledford 2007-06-01 10:03:47 EDT
The dependency on /usr/sbin/sendmail is there because mdadm specifically calls
that file and no other.  It was previously a dependency on MTA and was changed
during the merge review process.  As far as your system requiring manual
installation because you don't bother to build your custom postfix into an RPM
before installing it, well, that's to be expected.
Comment 2 Jordan Russell 2007-06-01 13:10:01 EDT
I understand that mdadm can call /usr/sbin/sendmail, and that in previous
FC/RHEL releases the dependency was on "smtpdaemon" instead.

My point is that virtually all other packages do not have such a dependency,
despite many of them being capable of sending mail (this includes vixie-cron,
smartd, and even mailx).

# rpm -qa | wc -l
390
# rpm -q --whatrequires /usr/sbin/sendmail
mdadm-2.6.1-4.fc7
# rpm -q --whatrequires smtpdaemon
no package requires smtpdaemon

mdadm's dependency on /usr/sbin/sendmail therefore strikes me as superfluous. It
shouldn't require an MTA package to be installed just because it "can" send
mail. Even if someone had no /usr/sbin/sendmail at all, the non-monitoring
functionality of mdadm would still work fine, AFAICS.
Comment 3 Doug Ledford 2007-07-10 16:39:56 EDT
Even though I closed this out as NOTABUG, I did in fact make the change.  The
mdadm-2.6.2-4.fc7 package in updates-testing has the requirement removed.

Note You need to log in before you can comment on or make changes to this bug.