Bug 242020 - Install to hard drive from LiveCD formats the hard disk when it says it won't
Install to hard drive from LiveCD formats the hard disk when it says it won't
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-06-01 06:46 EDT by Phil Mayers
Modified: 2011-10-26 20:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 10:55:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Phil Mayers 2007-06-01 06:46:25 EDT
Description of problem:

I did the following:

 * booted the x86_64 LiveCD into RAM
 * opened a terminal
 * lvchange -ay /dev/VolGroup00/LogVol00
 * mount /dev/VolGroup00/LogVol00 /mnt
 * cd /mnt
 * mkdir old
 * mv * old
 * cd
 * umount /mnt
 * double click the install to hard-drive icon
 * at the disk setup section, select the LogVol00 and DO NOT format the drive,
click through the warning about "should format" and again say "DO NOT format",
then install
 * system boots; drive has in fact been formatted

Version-Release number of selected component (if applicable):

F7 release version

How reproducible:

Have only tried once, will give it another go shortly when I find a spare PC

Steps to Reproduce:
1. follow above instructions
2. reboot into system
3. see that disk has been formatted
  
Actual results:

Data erased (thankfully I had nothing on this machine)

Expected results:

Data not be erased

Additional info:
Comment 1 Jeremy Katz 2007-06-04 15:01:46 EDT
The way the live install works, there's no way to avoid a "format"; we do a
direct copy of the filesystem used for the live image to the hard drive and then
resize accordingly.  

I'll try to make some adjustments so this is clearer in F8
Comment 2 Jeremy Katz 2007-09-10 10:55:17 EDT
This should be clearer as of Fedora 8, test2
Comment 3 Doug McCasland 2011-10-26 20:26:05 EDT
I was testing Fedora 15 Live CD, because I wanted to do the same thing as Phil did on a live system (in my case, to convert an Ubuntu desktop to Fedora).  

Before running the Install to Disk, I opened a shell, mounted an existing blank non-LVM ext4 file system, and created some test files on it.  I unmounted it.  I used the Custom feature of Install to indicate which file system to use for root and NOT format.  After running the Install, the root fs was re-formatted and the test files were gone (for the reason given by Jeremy).

There is no indication in the UI or doc that the root file system will be always be formatted and all existing data last.  It's even more surprising that it happens considering all the warnings in the UI and doc about losing data in every other case where a fs format is requested/required.

So for LiveCD, the root fs should not have an option to format -- instead, it should have a warning that it will be formatted.

Other than that, I'm liking F15!

Note You need to log in before you can comment on or make changes to this bug.