Bug 242043 - Kernel panic - not syncing: Attempted to kill init! !!
Kernel panic - not syncing: Attempted to kill init! !!
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 08:59 EDT by Bob Gustafson
Modified: 2008-02-14 08:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 08:15:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2007-06-01 08:59:46 EDT
Description of problem:

I downloaded F7 DVD and selected update option

System tried to boot old fc6 image at first (grub.conf default wrong)

I selected the fc7 in the grub menu and it still would not boot.

I booted the DVD in rescue mode and edited the /boot/grub/grub.conf so default
was 1 instead of 0

Tried to boot - still Kernel panic. Seems to be not finding my volume groups,
even though the volume groups are recognized fine in rescue mode.

Version-Release number of selected component (if applicable):

F-7-DVD.iso as downloaded a few hours ago. Checkmedia was run and it was OK

How reproducible:

Unfortunately, too reproducible

Steps to Reproduce:
1. install F7 as an update to uptodate FC6
2. boot
3.
  
Actual results:

Kernel panic - not syncing...


Expected results:

Clean boot

Additional info:

I took photos of my screen. Some data has run off the top, but I can enter what
you need.

At the top of my last screen is:

mdadm:/dev/md1 has been started with 2 drives.
Scanning logical volumes
  Reading all physical volumes. This may take awhile...
  No volume groups found
Activating logical volumes
  Volume group "rootvg" not found
Trying to resume from /dev/md1
No suspend signature on swap, not resuming.
...
...
Kernel panic
Comment 1 Bob Gustafson 2007-06-01 15:44:26 EDT
See bug 241949
Comment 2 Bob Gustafson 2007-06-01 23:40:59 EDT
See bug 237415

Problem may be with bad mkinitrd (kernel > 2.6.20-1.3069)
Comment 3 Bob Gustafson 2007-06-02 08:32:15 EDT
See fix - 3rd from last comment in bug 237415

Fix due to bbaetz@acm.org
Comment 4 Russell McOrmond 2007-06-07 16:23:39 EDT
I had a FC6 system which I upgraded using
'yum update' after installing the new fedora-release.

My / is on /dev/hda2 and my /boot is on /dev/hda1

I got the familiar error: mount: could not find filesystem '/dev/root'

I tried editing the 'init' to mount things differently, and now just get:
mount: could not findfilesystem '/dev/hda2'

Not sure if it is helpful for tracking this down to know that it isn't tied to
RAID or LVM, as suggested in some of the other bug reports.
Comment 5 Russell McOrmond 2007-06-07 16:46:33 EDT
Please ignore the last comment.  I found the note about the ata module, and the
fact that references to /dev/hda needed to be changed to /dev/sda

Comment 6 Joel Andres Granados 2008-02-14 08:15:07 EST
Seems to be fixed...  The issue was closed in 237415

Note You need to log in before you can comment on or make changes to this bug.