Bug 242048 - Missing dependency on freeglut
Missing dependency on freeglut
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: PyOpenGL (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 09:33 EDT by Eric Harney
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-03 10:45:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glchess output (1.46 KB, text/plain)
2007-06-01 09:33 EDT, Eric Harney
no flags Details

  None (edit)
Description Eric Harney 2007-06-01 09:33:50 EDT
My best guess is that this is a dependency problem with PyOpenGL... please
reassign if it's actually another package.

Description of problem:
Tried to enable 3d mode in glchess from gnome-games.  It told me to install
Python GL and GtkGLExt bindings for this to work.
I did a "yum install pygtkglext" and "yum install PyOpenGL".

After this, glchess fails to start.  (Silently, if running from the Gnome menu.)
 This is due to a failure to load libglut.so.3.  See attached output log.

"yum install freeglut" fixes this problem -- it appears it needs to be added as
a dependency to PyOpenGL.

Version-Release number of selected component (if applicable):
PyOpenGL-3.0.0-0.3.a6.fc7
pygtkglext-1.1.0-2.fc7

How reproducible:
Everytime

Steps to Reproduce:
1. yum install PyOpenGL pygtkglext
2. $ glchess
Comment 1 Eric Harney 2007-06-01 09:33:50 EDT
Created attachment 155876 [details]
glchess output
Comment 2 Hans de Goede 2007-06-02 02:24:30 EDT
Strange, because PyOpenGL already requires freeglut:
[hans@shalem ~]$ rpm -q --requires PyOpenGL
PyOpenGL-3.0.0-0.3.a6.fc7.noarch
freeglut  
libGL  
libGLU  
python(abi) = 2.5
python-numeric  
python-setuptools  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1

Could you try "rpm -q --requires PyOpenGL" on this system, as well as:
"rpm -q --whatprovides freeglut"

Maybe this is a x86_64 system and for some reason the i386 version of freeglut
was already installed?
Comment 3 Eric Harney 2007-06-03 09:45:04 EDT
Yes, that is exactly what happened - I had already pulled freeglut.i386 for
something else, so it didn't install the x86_64 freeglut when I installed
gnome-games.

"rpm -q --requires PyOpenGL" looks the same as yours.

# rpm -q --whatprovides freeglut    (after installing the x86_64 one)
freeglut-2.4.0-11.fc7
freeglut-2.4.0-11.fc7

Is there a way to have it depend on the 64 bit freeglut so that this doesn't happen?
Comment 4 Hans de Goede 2007-06-03 10:45:38 EDT
(In reply to comment #3)
> Is there a way to have it depend on the 64 bit freeglut so that this doesn't
happen?

I'm afraid currently this isn't possible and in this specific case its even
harder to achieve as PyOpenGL is a noarch package.

Note You need to log in before you can comment on or make changes to this bug.