Bug 242050 - Anaconda fails to recognize 4 partitions plus unreachable space
Anaconda fails to recognize 4 partitions plus unreachable space
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 09:42 EDT by A.J. Bonnema
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 16:59:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A.J. Bonnema 2007-06-01 09:42:38 EDT
Description of problem:

When installing FC7, I had a disk partition with 3 primary partitions and 1
extended partition. After the last (primary) partition there was a lot of free
space. I didn't at first realize that I had in effect the maximum number of
partitions, so I pointed to this free space when choosing mount points and
designated it as a new partition (ext3).
When I entered "OK" however, in stead of a remark, that the disk already had the
maximum number of (primary or extended) partitions, Anaconda crashed.
I repeated this, when I had found what the problem was: the crash is repeatable.

When I deleted one of the primary partitions I could designate the free space
fine. From that point on I could continue the install without problems.

Version-Release number of selected component (if applicable):
It is Anaconda from the DVD for installing FC7 on a x86_64 system.
The disk brand is (I guess) unimportant.

How reproducible:
Have a disk with 4 primary partitions or (as in my case) 3 primary partitions
plus one extended partition -- plus enough free space following the last primary
partition.

Steps to Reproduce:
1. Install FC7
2. Choose custom adapting the partitions
3. keep all primary and extended partition and designate the free space as a new
partition.
  
Actual results:
Anaconda crashes with a bugtrace.

Expected results:
Anaconda remarks on the maximum number of primary or extended partitions.
Possibly some extra verbal explanation using an example or something like that.
Not a crash.

Additional info:
None.
Comment 1 Jeremy Katz 2007-06-04 14:09:29 EDT
Can you provide the dump you received?
Comment 2 A.J. Bonnema 2007-06-04 21:32:23 EDT
No, at the time I had no medium to save the dump on.
Also, I can not recreate the situation without changing my harddisk.

Is there anyone else who could recreate the situation using a spare harddisk?
Comment 3 David Cantrell 2007-08-22 16:59:54 EDT
This appears fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.