Bug 242152 - Embedded GRUB menu prevents kernel startup and Fedora install on Sony Vaio PCV-RS724G
Embedded GRUB menu prevents kernel startup and Fedora install on Sony Vaio PC...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 17:09 EDT by Exile In Paradise
Modified: 2008-06-16 21:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:21:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Exile In Paradise 2007-06-01 17:09:43 EDT
Description of problem:
Downloaded F7 i386 install DVD ISO, verified SHA1SUMs, burned with verify.
Put into a bone stock (no additional hardware) Sony Vaio PCV-RS724G desktop x86
system. GRUB loaded. A linux: prompt flashed on screen for less than a second
and disappears, replaced with F7 graphical install menu that has Install,
Install (text), Rescue, and Boot Disk OS options.
Choosing any of the first 3 options:
vmlinuz ......................
initrd ...............................................
Ready.
System hangs after the word "Ready." until power cycled.

Version-Release number of selected component (if applicable):
Embedded menu and default GRUB shipped on Fedora 7 i386 DVD ISO

How reproducible:
Completely. Happens every time the embedded menu is displayed, exactly the same
as described above. vmlinuz and initrd show lots of '.' while GRUB loads them,
the word Ready, and lockup.

Steps to Reproduce:
1. Insert Fedora 7 i386 install DVD into bone stock Sony Vaio PCV-RS724G and
power on.
2. Wait for the GRUB graphical menu and choose Install, Install (text), or
Rescue option.
3. Watch it load vmlinuz and initrd, print "Ready." and hang.
  
Actual results:
System hangs after loading vmlinuz, initrd, and displaying the word "Ready."

Expected results:
GRUB hand control to kernel, kernel uncompress and begin boot.

Additional info:
I ran into this same mess with F7t4 and F7RC2. Sorry, but I did not enter bug
report for those because a) I didn't know if it was Fedora or something with
Sony's hardware and supplied BIOS and b) I had no workaround, and without that,
nothing particularly useful to enter other than "it no worky on only my system?"

However, I burned F7 install to "try again". First, I removed all additional
hardware, restored the disk to factory state using the Sony recover CDs, and
reset all BIOS options to default. Boot from Fedora DVD still hangs. Began
seriously monkeying with the TAB option to add everything I could think of after
the vmlinuz line, including internet workaround described for Sony notebooks. No
good. I tried all sorts of combinations of apci, pci, and other options. All of
them resulted in the same lock. I finally found that I could get out of the
menu. When the embedded menu displays, if I press ESCAPE key, I get dumped to
GRUB with a boot: prompt. I tried a raft of GRUB commands there, to no avail.

A workaround:
When the graphical menu displays, press ESCAPE and return to the GRUB boot
prompt. From the boot prompt, I used either the "linux", "linux rescue", or
"linux memtest86" command (sorry, can't remember exactly which now, it was
almost 2am by this time). From that boot: prompt, with a linux command, Fedora 7
booted normally, ran Anaconda, installed, and everything is great. I just had to
get out of that menu, enter a linux command by hand, and start the installer
from boot: rather than the graphical menu. After install, system rebooted fine
and has booted without problem since. The workaround was only needed to get it
to start the installer, not boot every time once installed.
Comment 1 Exile In Paradise 2007-06-04 09:09:50 EDT
May be related to: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=239585
I believe the Sony Vaio PCV-RS724G uses an ASUS motherboard, but I am not sure
of the specific model.
Comment 2 Exile In Paradise 2007-06-04 11:25:19 EDT
Got out the screwdriver and violated the computer rather abruptly.
The Sony Vaio PCV-RS724G I got from Sony came with an Asus PTGD-VX, but I can't
find any usable information about the board from a casual web or Asus search.
Comment 3 Bug Zapper 2008-05-14 08:43:21 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2008-06-16 21:21:21 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.