Bug 242167 - autocache generates stack trace
Summary: autocache generates stack trace
Status: CLOSED DUPLICATE of bug 242162
Alias: None
Product: Fedora
Classification: Fedora
Component: mock   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-01 22:18 UTC by Wart
Modified: 2013-01-10 01:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-03 00:38:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wart 2007-06-01 22:18:48 UTC
Description of problem:
Using the --autocache option with mock in F7 generates a python stack trace.  To
my untrained eye, it appears that the yum.conf symlink is unpacked as part of
the autocache, and then mock tries to create it a second time after unpacking
the cached root.
 
[rpmbuild@owl ~]$ time mock -r core7-64 --autocache
/space/src/fedora/vavoom/F-7/vavoom-1.23.1-1.fc7.src.rpm 
init
clean
prep
This may take a while
unpack cache
Traceback (most recent call last):
  File "/usr/bin/mock", line 1046, in <module>
    main()
  File "/usr/bin/mock", line 1043, in main
    do_rebuild(config_opts, srpms)
  File "/usr/bin/mock", line 910, in do_rebuild
    my.prep()
  File "/usr/bin/mock", line 254, in prep
    self._prep_install()
  File "/usr/bin/mock", line 659, in _prep_install
    os.symlink('../yum.conf', os.path.join(yumdir, 'yum.conf'))
OSError: [Errno 17] File exists

real    0m20.154s
user    0m7.986s
sys     0m7.151s

Version-Release number of selected component (if applicable):
mock-0.6.12-1.fc7.x86_64

Comment 1 Julian Sikorski 2007-06-03 00:38:11 UTC

*** This bug has been marked as a duplicate of 242162 ***


Note You need to log in before you can comment on or make changes to this bug.