Bug 242169 - Need read access to /dev/loopX serving a mounted ISO image
Summary: Need read access to /dev/loopX serving a mounted ISO image
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-01 22:32 UTC by James Hawkins
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 08:51:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Hawkins 2007-06-01 22:32:07 UTC
Description of problem:

When you mount an ISO image using 'sudo mount -o loop image.iso /media/cdrom',
you are not given read access to the loop file representing the image
(/dev/loopX).  volname /dev/loopX should return the volume name of the mounted
image, like you would get for a mounted physical CD (/dev/hdX).  In order to
work around this, I 'sudo chown myuser /dev/loopX'.  This is important in order
to install software from ISO images in Wine, which reads the volume name in
order to handle media switching.


Version-Release number of selected component (if applicable):

Fedora Core 6

How reproducible:

Always.


Steps to Reproduce:
1. sudo mount -o loop image.iso /media/cdrom
2. volname /dev/loopX

where X is the actual loop device number.
  
Actual results:

No volume name is available because of insufficient permissions.

Expected results:

This should be able to give the volume name of the image, just as though it were
a physical CD device.

Extra information:

I marked this as a bash component, but I'm really not sure what component it
should be.

Comment 1 Tim Waugh 2007-06-04 16:30:26 UTC
Fixed component and reassigning.

Comment 2 Harald Hoyer 2007-06-05 08:51:42 UTC
err... /dev/loop cannot be given read-all permissions by default. Since you can
mount as root, you can chmod also.


Note You need to log in before you can comment on or make changes to this bug.