Bug 242184 - F7 Installation Hang up
F7 Installation Hang up
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
7
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Peter Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 20:59 EDT by Alexandre Mandl
Modified: 2008-06-16 21:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:21:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
AMD64-3200 lspci output (2.52 KB, text/plain)
2007-06-02 04:56 EDT, Laurent Papier
no flags Details
Sempron2500 lspci output (1.70 KB, text/plain)
2007-06-02 04:56 EDT, Laurent Papier
no flags Details
Asus P5AD2 lspci (2.13 KB, text/plain)
2007-06-02 06:39 EDT, Edouard Bourguignon
no flags Details
lspci output (1.66 KB, text/plain)
2007-08-15 07:06 EDT, Chris Parkin
no flags Details

  None (edit)
Description Alexandre Mandl 2007-06-01 20:59:28 EDT
I've tried many times to install Fedora 7 into my Dell Desktop (Pentium HT) and
it just hang up during the start.

I choose the type of installation during the first menu and it comes:

Loading vmlinuz....
Loading initrd.img.......
Ready
Comment 1 Joshua M. Thompson 2007-06-01 21:06:45 EDT
Confirmed here as well on my Dell Dimension 5150. Currently I'm running a fully
updated FC6 without problems but the install DVD for F7 just hangs at "Ready".
The DVD passed its checksum test when booting on my notebook and in fact my
notebook is currently doing the FC6->F7 upgrade from from it.
Comment 2 Bill Nottingham 2007-06-01 21:50:22 EDT
What happens if you pass 'maxcpus=1'?
Comment 3 Alexandre Mandl 2007-06-01 23:56:56 EDT
Nothing
Comment 4 Laurent Papier 2007-06-02 04:54:27 EDT
I have the same problem on my 2 computers.
I tried to install FC7-i386 on a AMD64-3200 and on a Sempron2500.
I guess maxcpus=1 won't help has I have no HT or Dualcore CPUs.

For more detail infos about my hardware, I attach lspci output.

Comment 5 Laurent Papier 2007-06-02 04:56:32 EDT
Created attachment 155969 [details]
AMD64-3200 lspci output
Comment 6 Laurent Papier 2007-06-02 04:56:56 EDT
Created attachment 155970 [details]
Sempron2500 lspci output
Comment 7 Edouard Bourguignon 2007-06-02 06:38:39 EDT
same problem here on a Asus P5AD2 with P4HT
can't install

dvd, and even rescue cd can't boot! 
Comment 8 Edouard Bourguignon 2007-06-02 06:39:53 EDT
Created attachment 155974 [details]
Asus P5AD2 lspci
Comment 9 Dmitri A. Sergatskov 2007-06-02 12:21:11 EDT
I have the same problem trying to install f7-x86_64 on the following computer:
http://smolt.fedoraproject.org/show?UUID=b30a8f0b-9f93-4112-9154-e568f920afb6
At boot my keyboard (USB) is dead -- I cannot even select items from 
the boot menue, less passing some parameters to the kernel.
Comment 10 Paulo da Silva 2007-06-02 13:24:10 EDT
Same thing here.
'Ready.' message after reading vmlinuz and initrd.img.
lspci output:

00:00.0 Host bridge: Intel Corporation 82925X/XE Memory Controller Hub (rev 0e)
00:01.0 PCI bridge: Intel Corporation 82925X/XE PCI Express Root Port (rev 0e)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface
Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE
Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 82801FR/FRW (ICH6R/ICH6RW) SATA
Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 04)
01:04.0 Mass storage controller: Integrated Technology Express, Inc. IT/ITE8212
Dual channel ATA RAID controller (rev 13)
01:05.0 Mass storage controller: Silicon Image, Inc. SiI 3114
[SATALink/SATARaid] Serial ATA Controller (rev 02)
01:09.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
01:09.1 Input device controller: Creative Labs SB Audigy Game Port (rev 04)
01:09.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04)
01:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
01:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
03:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600] (rev a2)
Comment 11 Edouard Bourguignon 2007-06-03 05:04:24 EDT
upgrading with yum works great, kernel is booting fine

only the anaconda kernel on the F7 cds/dvd seems to hang

http://smolt.fedoraproject.org/show?UUID=0c74913c-ee06-4022-8a03-20383ca6a2f9
Comment 12 lynn wheeler 2007-06-03 12:34:51 EDT
same here,  dell dimension, promise/sata disk controller. all the F7 cdroms &
dvds hang after ready message (with any combination of initial workarounds).
Running current/uptodate FC6. Have found some warnings that fc6->f7 yum upgrade
might fail (also) ... potential of disk driver not being properly configured.
Comment 13 Joshua M. Thompson 2007-06-04 21:03:51 EDT
I too just did a successful yum upgrade of my machine from FC6 to F7 and it's
running just fine. At this point I'm going to make a guess that perhaps the real
problem is with syslinux/extlinux and not the kernel. This would explain why
neither the installer nor the livecds boot on these machines, and why no other
kernels seem to exhibit this problem.

When I get some time later I will try making a livecd from my machine and see if
it boots or not. If it doesn't then the bootloader is most likely at fault.
Comment 14 Alexandre Mandl 2007-06-05 11:23:14 EDT
I've tried to upgrade to Fedora 7 from Fedora 6. No success.
Uhm... yum prompted me with some strange messages. I don't no why.

Can you inform us the command line that you use to upgrade to F7?
Tks a lot.
Comment 15 Edouard Bourguignon 2007-06-05 14:47:23 EDT
first you need to upgrade fedora-release and fedora-release-notes
take care about the new repo files in /etc/yum.repos.d 

then:
yum upgrade

that's all
Comment 16 Paul Friel 2007-06-09 15:26:29 EDT
Here's a work around if (like me) your machine hangs at the "Ready" message i.e.
when you try to install Fedora from a DVD it hangs at the "Ready" msg here: 

  Loading vmlinuz....
  Loading initrd.img.......
  Ready                         <--- machine hangs

The work around was found by LarryT at the link below (I'm just reproducing his
work here to help others stuck on this bug & unable to install F7)

    http://forums.fedoraforum.org/forum/showthread.php?t=156491

The work around is to copy the diskboot.img file from the Fedora DVD to a USB
key and then boot off the USB key (with the fedora DVD in your DVD drive). After
you've booted off the USB key, anaconda will find the DVD and install fedora 7.
Steps to create a bootable USB key are roughly (this will wipe the contents of
your USB key btw) 
   
    Place your F7 media in your DVD drive, then...
    
    mkdir /mnt/dvd
    mount /dev/dvd /mnt/dvd
    dd if=/mnt/dvd/images/diskboot.img of=/dev/<your_usb_key_device_here>

Then reboot your machine and boot off the  USB key - it should get you past the
hang at the "Ready" msg and allow you to install F7- it worked for me!
     
Comment 17 Peter Jansen 2007-06-21 02:25:36 EDT
I have a dell 5150 machine which also would hang at the ready stage.

I found that in the BIOS turning on the SATA compatibility mode allowed it to
boot from CD ROM. 
Comment 18 Chris Parkin 2007-08-15 07:06:42 EDT
Created attachment 161341 [details]
lspci output

Same problem here using x86_64
Comment 19 Bug Zapper 2008-05-14 08:43:45 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Bug Zapper 2008-06-16 21:21:44 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.