Bug 242202 - [FAQ] How to use a local yum mirror before the official ones
[FAQ] How to use a local yum mirror before the official ones
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: James Antill
http://fedoraproject.org/wiki/Docs/Dr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 02:52 EDT by Răzvan Sandu
Modified: 2014-01-21 17:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 14:13:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2007-06-02 02:52:36 EDT
Description of problem:

Hello,

IMHO, this documentation-related bug is almost a FAQ and refers to the default
yum configuration present in Fedora 7 (yum package and .repo files from
fedora-release package).

Please suppose that, on a standard F7 machine, an administrator has an exact
copy of an F7 mirror *inside* a LAN, in order to provide online updates to a lot
(tens or hundreds) of Fedora boxes around (and to save bandwidth for the
official mirrors, speeding up the whole process).

So this copy *is not* in the official mirror list (since it is behind
NAT/firewall and it's not even visible in Internet).

Now what we want is to prioritize access for online updates (starting from the
default configuration of yum, with as little manual modification in Linux
clients' yum config files as possible):

- first, a client should check the local (LAN) mirror for updates;
- if this fails, client should go to local Internet mirrors. *Please note* that
geographically-closest mirrors are not necessarily the faster ones, due to
strange peering agreements between various ISPs;
- the ultimate source should be authoritative Fedora mirrors (Red Hat,
mother-site ?).

Please provide a recommended/supported way of reaching this functional goal,
starting from default configuration files included in the distro.

Regards,
Răzvan


Version-Release number of selected component (if applicable):
yum-3.2.0-1.fc7.noarch.rpm
fedora-release-7-3.noarch.rpm


How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
There is no standard guide/piece of documentation or default config file that
describes how to properly obtain such a failover configuration.

Expected results:
The piece of documentation or default config file should exist.

Additional info:
Comment 1 Doncho N. Gunchev 2007-06-06 13:18:04 EDT
I use only local mirror for now (most of the time), but I saw you can use both
'baseurl' and 'mirrorlist'. What would be the behavior in this case? Would that
make yum search each package in the 'baseurl' repo and then look in the
'mirrorlist'?
Comment 2 Charles Curley 2007-06-22 10:13:06 EDT
I have a similar situation: I have a local repo of F7, using the DVD. I prefer
that clients pull from it instead of the Fedora repo. I don't know that this is
a perfect solution, but it seems to work:

* Create your local repo, as above.

* Create a repo file, say "fedora-core.repo", with the key stanza:

--------------------------------------------------
[core]
name=Fedora Core $releasever - $basearch
baseurl=ftp://charlesc/pub/f$releasever/F-$releasever-i386-DVD.iso
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
file:///etc/pki/rpm-gpg/RPM-GPG-KEY
--------------------------------------------------

and modify the URL to suit.

* Install yum-fastestmirror. I don't know if you have to have it to make this
work, but it seemed like a good idea at the time.

Clients seem to pull from the core repo when they can.
Comment 3 Jeremy Katz 2007-09-13 14:13:16 EDT
Local mirrors that are for behind a NAT only can in fact be set up and
registered with the primary mirror infrastructure
(http://mirrors.fedoraproject.org) so that you get pointed at the right place
from the mirrorlist for your NAT.  See there for the docs about setting up.

Note You need to log in before you can comment on or make changes to this bug.