Bug 242223 - X crach when Ati proprietary driver is loaded
Summary: X crach when Ati proprietary driver is loaded
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
urgent
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-02 10:27 UTC by Alphonse Van Assche
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-06 18:28:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log (15.26 KB, text/plain)
2007-06-02 10:27 UTC, Alphonse Van Assche
no flags Details

Description Alphonse Van Assche 2007-06-02 10:27:08 UTC
Description of problem:

X crache when the ati fglrx driver is loaded

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-5.fc7
xorg-x11-drv-fglrx-8.37.6-1.fc7
kmod-fglrx-8.37.6-1.2.6.21_1.3194.fc7

How reproducible:

1. Install the ati driver and setup xorg.conf.
2. Try to restart X.

  
Actual results:
Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x81) [0x80ceb41]
1: [0xc94420]
2: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxMiscReadPCIConfig+0x16b)
[0x31affb]
3: /usr/lib/xorg/modules/drivers//fglrx_drv.so(swlCailCbGetPciBusData+0x4c)
[0x34093c]
4: /usr/lib/xorg/modules/drivers//fglrx_drv.so [0x34e0c8]
5: /usr/lib/xorg/modules/drivers//fglrx_drv.so(CailIsPCIExpressBoard+0x1a)
[0x34bdca]
6: /usr/lib/xorg/modules/drivers//fglrx_drv.so(Cail_PreInit_AsicCaps+0x75)
[0x34c005]
7: /usr/lib/xorg/modules/drivers//fglrx_drv.so(CAILEarlyASICInit+0x172) [0x349182]
8: /usr/lib/xorg/modules/drivers//fglrx_drv.so(swlCailLinuxInit+0x205) [0x33e965]
9: /usr/lib/xorg/modules/drivers//fglrx_drv.so [0x314810]
10: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxPreInit+0x725) [0x30f7e5]
11: /usr/bin/Xorg(InitOutput+0x9a8) [0x80a2f68]
12: /usr/bin/Xorg(main+0x27b) [0x8070e8b]
13: /lib/libc.so.6(__libc_start_main+0xe0) [0x4969af70]
14: /usr/bin/Xorg(FontFileCompleteXLFD+0x1e1) [0x8070391]

Expected results:
To be able to load that driver.

I know that is not the business of the community to work on proprietary stuff.
But have see that some work have be done on the selinux policies to be able to
load that driver.

Comment 1 Alphonse Van Assche 2007-06-02 10:27:09 UTC
Created attachment 155973 [details]
Xorg.log

Comment 2 Adam Jackson 2007-06-06 18:28:23 UTC
Segfault is in fglrx, not core X code.  This is not a bug we can fix, sorry.

Comment 3 Alphonse Van Assche 2007-06-06 20:04:30 UTC
Thanks for the info


Note You need to log in before you can comment on or make changes to this bug.