Bug 242226 - Albums play in wrong order
Summary: Albums play in wrong order
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gmpc (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Adrian Reber
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-02 11:16 UTC by David Woodhouse
Modified: 2008-01-15 22:59 UTC (History)
0 users

Fixed In Version: 0.15.5.0-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 22:59:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
make it sort when displaying and adding tracks to playlist (9.36 KB, patch)
2007-06-07 17:17 UTC, David Woodhouse
no flags Details | Diff
better patch (4.02 KB, patch)
2007-06-13 10:03 UTC, David Woodhouse
no flags Details | Diff
sort on album/disc/track (4.18 KB, patch)
2007-06-13 10:19 UTC, David Woodhouse
no flags Details | Diff

Description David Woodhouse 2007-06-02 11:16:24 UTC
If I use the 'Browse Artists' tool I see a list of artists, and inside each
artist "folder" there is a "folder" for each album.

However, the tracks in that album are displayed in the wrong order, even though
gmpc does seem to _know_ the order -- if I right-click on a track and select
'Information', the track number is displayed correctly. It must be in the id3
tags -- and it's certainly available in the .m3u files which match each album,
although I suspect gmpc/mpd don't really associate the two.

When I add the album to the playlist, the tracks are also added in the wrong
order. (Unless I use the 'Browse Filesystem' option and just add the .m3u file,
of course. But that lacks the subdivision by artists and the album art, etc.)

Comment 1 David Woodhouse 2007-06-07 17:17:28 UTC
Created attachment 156490 [details]
make it sort when displaying and adding tracks to playlist

Comment 2 David Woodhouse 2007-06-12 13:12:45 UTC
http://musicpd.org/mantis/view.php?id=1512

Comment 3 David Woodhouse 2007-06-13 10:03:30 UTC
Created attachment 156857 [details]
better patch

Comment 4 Adrian Reber 2007-06-13 10:11:54 UTC
I will apply the patch and request a build as soon as I have figured out how it
all works with koji.

Comment 5 David Woodhouse 2007-06-13 10:19:42 UTC
Created attachment 156860 [details]
sort on album/disc/track

Upstream maintainer requested to use album/disc/track for sort order instead of
just album/track. New patch...

Comment 6 Fedora Update System 2007-06-25 23:22:17 UTC
gmpc-0.14.0-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2007-06-28 01:48:05 UTC
gmpc-0.14.0-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 David Woodhouse 2007-12-16 11:57:51 UTC
This seems to have regressed in F8.

Comment 9 Adrian Reber 2007-12-23 19:09:21 UTC
In 0.15.5.0 this seems to be fixed. I have updated rawhide; F8 and F7 will
follow soon.

Comment 10 David Woodhouse 2008-01-03 01:29:47 UTC
It seems to add them in the right order now, but still doesn't display them in
the right order when you select them in the Artist Browser.

Comment 11 Fedora Update System 2008-01-03 01:34:15 UTC
gmpc-0.15.5.0-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gmpc'

Comment 12 Adrian Reber 2008-01-03 18:07:22 UTC
The new artist browser let's you select after which criteria to sort the albums
if you click on one of the column headers. In my tests it seems to remember the
sorting order once it has been selected.

Comment 13 Fedora Update System 2008-01-15 22:59:09 UTC
gmpc-0.15.5.0-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.