Bug 242242 - docbook-simple.cat shows as being modified by rpm -V after a fresh install
Summary: docbook-simple.cat shows as being modified by rpm -V after a fresh install
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: docbook-simple   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-02 16:29 UTC by Bruno Wolff III
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 14:39:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bruno Wolff III 2007-06-02 16:29:51 UTC
Description of problem:
After a fresh install running rpm -V shows /etc/sgml/docbook-simple.cat as being
changed. Since it isn't marked as a config file this makes one worry when
checking the integrity of the system using rpm -V.

Version-Release number of selected component (if applicable):
1.0-2.1.1

How reproducible:
100%


Steps to Reproduce:
1. rpm --force -U docbook-simple-1.0-2.1.1.noarch.rpm
2. rpm -V docbook-simple
3.
  
Actual results:
S.5....T   /etc/sgml/docbook-simple.cat


Expected results:
No files being flagged.

Additional info:
docbook-slides has the same problem with /etc/sgml/docbook-slides.cat .

Comment 1 Ondrej Vasik 2007-10-23 15:13:39 UTC
I think this issue is not necessary to be fixed in current release, I will fix
this with %config(noreplace) of those catalog files, because I'm now doing
rpmlint checks of docbook packages. Moving version to DEVEL, this issue will be
fixed during rpmlint corrections.

Comment 2 Ondrej Vasik 2007-10-24 14:39:12 UTC
rpmlint corrections done, built as docbook-simple-1.1-2.fc9 , file is marked as
configuration, is modified in %post (workaround of some older bug). If the mark
as configuration file is not enough for you, there will be necessary some
changes to fix the old bug some other way. I prefer to keep it like that.
Closing RAWHIDE.
Note: With docbook-slides-3.4.0-2.fc9 it is the same.

Comment 3 Bruno Wolff III 2007-10-24 17:59:05 UTC
That seems like a reasonable compromise. While it isn't a normal config file, it
does make it so when you see the file has changed, that it is less worrisome.


Note You need to log in before you can comment on or make changes to this bug.