Bug 242250 - ntfs-config crashes on startup
Summary: ntfs-config crashes on startup
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ntfs-config   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Xavier Lamien
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-02 17:45 UTC by David Kovalsky
Modified: 2014-03-31 23:44 UTC (History)
2 users (show)

Fixed In Version: 1.0-0.3.rc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 16:16:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Kovalsky 2007-06-02 17:45:22 UTC
Reproducable everytime trying to run ntfs-config from root terminal:
root@kovinek ~]# ntfs-config
Traceback (most recent call last):
  File "/usr/bin/ntfs-config", line 30, in <module>
    from NtfsConfig.NtfsConfig import *
  File "/usr/lib/python2.5/site-packages/NtfsConfig/NtfsConfig.py", line 36, in
<module>
    from Fstab import *
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Fstab.py", line 34, in <module>
    info = get_diskinfo_backend()()
  File "/usr/lib/python2.5/site-packages/NtfsConfig/DiskInfo.py", line 47, in
get_diskinfo_backend
    conf = Config()
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Config.py", line 44, in __init__
    self.read_config()
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Config.py", line 65, in
read_config
    self.user_config = get_user("dir") + CONF_FILE
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Utility.py", line 75, in
get_user
    user = pwd.getpwuid(os.environ["USER"])
TypeError: an integer is required

Note that running from menu from KDE works as expected.

The same with ntfs-config-root:
[root@kovinek ~]# ntfs-config-root
Traceback (most recent call last):
  File "/usr/sbin/ntfs-config-root", line 28, in <module>
    from NtfsConfig import Dialogs
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Dialogs.py", line 33, in
<module>
    from Fstab import *
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Fstab.py", line 34, in <module>
    info = get_diskinfo_backend()()
  File "/usr/lib/python2.5/site-packages/NtfsConfig/DiskInfo.py", line 47, in
get_diskinfo_backend
    conf = Config()
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Config.py", line 44, in __init__
    self.read_config()
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Config.py", line 65, in
read_config
    self.user_config = get_user("dir") + CONF_FILE
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Utility.py", line 75, in
get_user
    user = pwd.getpwuid(os.environ["USER"])
TypeError: an integer is required

running '/usr/bin/ntfs-config-root' works, '/usr/bin/ntfs-config' backtraces too
though.
[root@kovinek ~]# ntfs-config-root
Traceback (most recent call last):
  File "/usr/sbin/ntfs-config-root", line 28, in <module>
    from NtfsConfig import Dialogs
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Dialogs.py", line 33, in
<module>
    from Fstab import *
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Fstab.py", line 34, in <module>
    info = get_diskinfo_backend()()
  File "/usr/lib/python2.5/site-packages/NtfsConfig/DiskInfo.py", line 47, in
get_diskinfo_backend
    conf = Config()
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Config.py", line 44, in __init__
    self.read_config()
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Config.py", line 65, in
read_config
    self.user_config = get_user("dir") + CONF_FILE
  File "/usr/lib/python2.5/site-packages/NtfsConfig/Utility.py", line 75, in
get_user
    user = pwd.getpwuid(os.environ["USER"])
TypeError: an integer is required

Comment 1 Xavier Lamien 2007-06-02 18:36:58 UTC
hi,

I will check this out

Comment 2 Mamoru TASAKA 2007-06-12 06:31:13 UTC
Seems to be fixed in RC4.

Actually pwd.getpwuid(os.environ["USER"]) should be
pwd.getpwnam(os.environ["USER"])

Comment 3 Xavier Lamien 2007-06-12 15:50:50 UTC
that's right

The rc4 has been built, it'll be available

Comment 4 Mamoru TASAKA 2007-06-12 15:56:16 UTC
Umm..

Current ntfs-config is 1.0-0.2.beta1.fc7 and 1.0-0.2 > 1.0-0.1
so this wont be updated.

Also, please close as "ERRATA" when the fix appears as a update,
in current release.

Comment 5 Mamoru TASAKA 2007-06-12 15:59:14 UTC
(In reply to comment #4)
> Also, please close as "ERRATA" when the fix appears as a update,
> in current release.

I meant "as a update, *not* in current release".

Comment 6 Xavier Lamien 2007-06-12 16:16:28 UTC
^^

rebuilt to 1.0-0.3.rc4

Comment 7 Mamoru TASAKA 2007-06-12 16:45:57 UTC
Confirmed. Actually works. Thank you!
Also please rebuild -0.3 on devel repo.

Comment 8 Xavier Lamien 2007-06-12 17:50:01 UTC
done ;)

Comment 9 David Kovalsky 2007-06-13 08:28:45 UTC
Works for me too, thanks!


Note You need to log in before you can comment on or make changes to this bug.