Bug 242257 - IDE drives connected to JMB363 detected as SCSI/SATA
IDE drives connected to JMB363 detected as SCSI/SATA
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 15:55 EDT by bm
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 19:17:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bm 2007-06-02 15:55:45 EDT
Description of problem:

During install IDE drives (connected to the JMB363 controller on a P5B Deluxe
Wifi) are detected as SCSI/SATA, resulting in a message something like "linux
cannot recognize partitions beyond /dev/sda15".  


Version-Release number of selected component (if applicable):

Version used on F7 x86_64 install disk

How reproducible:

Always

Steps to Reproduce:
1. Start install on a computer with an IDE hard drive connected to a JMB363
controller, where the hard drive has more than 15 partitions (11 in extended)
2.
3.
  
Actual results:

Upgrade from FC6 failed, after ignoring a lot of messages about will not see
partitions, failed when trying to activate swap (I think since swap is on my 3rd
harddrive which actually is SATA and is /dev/sda2 on FC6 but /dev/sdc2 in F7
install).

Straight install results in messages about partitions will not be recognized,
presumably if I install I wont be able to use those partitions

Expected results:

Installs and I can use all the partitions on my IDE drives

Additional info:
I have only tried install on this computer.  I am presuming it is a problem of
the way linux deals with drives attached to the JMB363 controller, but for all I
know it may be a more general problem of IDE drives with more than 15 partitions
if all IDE drives are treated as SCSI.  On FC6 (original kernel and current
2.6.20-1.2952.fc6 kernel) my IDE drives are recognized as hde and hdf (which is
a little strange since I would expect hda and hdb). If I remember correctly when
I was using the vanilla kernel 2.6.20-rc1-git7 it detected these as hdc and hdd).
Comment 1 Chuck Ebbert 2007-06-04 19:17:06 EDT
Unfortunately there is no solution for this problem. The SCSI subsystem
cannot use more than 15 partitions per drive.

Note You need to log in before you can comment on or make changes to this bug.