Bug 242258 - rhgb does not work in Fedora 7 x86_64
rhgb does not work in Fedora 7 x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 16:01 EDT by Iosif Chatzimichail
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 09:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grub.conf (659 bytes, application/octet-stream)
2007-06-02 16:01 EDT, Iosif Chatzimichail
no flags Details

  None (edit)
Description Iosif Chatzimichail 2007-06-02 16:01:37 EDT
Description of problem:
rhgb is not installed after installation (KDE x86_64 live) and does not appear
even though it gets installed later and appears in grub.conf.

How reproducible:
Download the KDE x86_64 LiveDVD. Boot and install Fedora 7. Upon boot there is
no graphical boot screen.

Steps to Reproduce:
1. Download the KDE x86_64 LiveDVD.
2. Install Fedora 7.
3. Rhgb is not installed.
4. Even if you install it rhgb does not appear (it is correctly in the grub.conf
boot line)
  
Actual results:
During boot you see text instead of graphical boot. Fedora 7 looks much less
polished at the eyes of the general user or in a presentation.

Expected results:
The graphical boot should appear like:
http://fedoraproject.org/images/screenshots/booting-screen.jpg

Additional info:
I have only tested on KDE x86_64 live CD.
Comment 1 Iosif Chatzimichail 2007-06-02 16:01:38 EDT
Created attachment 155992 [details]
grub.conf
Comment 2 Robin Green 2007-07-06 04:35:47 EDT
I am seeing this as well. I installed from the KDE x86 live CD, so it's not
specific to x86_64.

After I install rhgb and reboot, I see this at the top of /etc/rhgb/temp/xorg.log:

_XSERVTransmkdir: ERROR: Cannot create /tmp/.X11-unix
Comment 3 Robin Green 2007-07-06 05:29:12 EDT
Actually, the real error was missing fonts. I had to do "yum install
xorg-x11-fonts-misc xorg-x11-fonts-base", and then it worked.

Perhaps a dependency needs to be added to the RPM?
Comment 4 Ray Strode [halfline] 2007-07-06 11:20:42 EDT
Well the dependency shouldn't be in RHGB, either xorg-x11-server I guess or the
comps file for the kde livecd.  Not sure which.

Moving to xorg-x11-server for now.
Comment 6 Adam Jackson 2007-07-09 10:21:02 EDT
I'm not really sure about this one.  It sounds like rhgb's X server is failing
to start because it's missing some fonts, but that shouldn't be happening.  The
only mandatory fonts are fixed and cursor, and they're both compiled into the
font library.

I'll look into it though.
Comment 7 Ray Strode [halfline] 2007-07-09 10:47:12 EDT
So Adam I looked at this today.

rhgb is setting a hard coded font path to the X server command line, which
disables font builtins.

The fix is either to add ,built-ins to the fontpath, or just drop the -fp arg
completely.
Comment 8 Ray Strode [halfline] 2007-07-27 13:40:32 EDT
should be fixed in rhgb-0.17.6-2.fc8
Comment 9 Jesse Keating 2007-07-30 09:40:09 EDT
This is still a problem.  Based on this mornings conversation, it sounds like
we're getting an SELinux denial writing to the log file in tmpfs and falling over.
Comment 10 Jesse Keating 2007-07-30 09:53:03 EDT
Disregard last message. Wrong bug.

Note You need to log in before you can comment on or make changes to this bug.