Bug 242262 - Fedora 7 2.6.21-1.3 kernel has IDE disabled by default
Fedora 7 2.6.21-1.3 kernel has IDE disabled by default
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 16:16 EDT by WebMasters, Inc. Support
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 17:04:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config files from FC6 and FC7 as well as working 2.6.21.3 config upgraded from FC6 config (220.00 KB, application/x-tar)
2007-06-02 16:18 EDT, WebMasters, Inc. Support
no flags Details

  None (edit)
Description WebMasters, Inc. Support 2007-06-02 16:16:17 EDT
Description of problem:

When upgrading from FC6 to F7 via yum, the new kernel 2.6.21 omitted a bunch of
IDE modules and includes that are needed on some hardware.  Was this intended? 
A lot of equipment from online dedicated server centers still use IDE drives and
users are going to have upgrade problems because of this.

The IDE modules were included in 2.6.18 and this omission seems to be the
largest omission when comparing the two kernel config files.  It was not
mentioned in the release notes that these were going to be disabled.

Version-Release number of selected component (if applicable):

kernel 2.6.18.fc6
kernel 2.6.21.fc7

How reproducible:

On any working FC6 system using IDE controller, after upgrading to FC7, the
machine will not reboot properly.

Steps to Reproduce:
1. Install FC6 on IDE controlled machine
2. Upgrade FC6 to latest
3. Issue RPM command to download latest FC7 release file from repo
4. Issue yum update to go to FC7
5. Reboot will panic.

  
Expected results:

Existing IDE machines should be able to work with this release.

Additional info:

Will attach config-2.6.18, config-2.6.21 from Fedora.  Will also attach .config
of make oldconfig on 2.6.21.3 from config-2.6.18
Comment 1 WebMasters, Inc. Support 2007-06-02 16:18:54 EDT
Created attachment 155993 [details]
Config files from FC6 and FC7 as well as working 2.6.21.3 config upgraded from FC6 config

Config files from FC6 and FC7 as well as working 2.6.21.3 config upgraded from
FC6 config
Comment 2 WebMasters, Inc. Support 2007-06-02 19:34:07 EDT
Found this in the release notes for FC7:

http://docs.fedoraproject.org/release-notes/f7/en_US/sn-Kernel.html

New IDE drivers that use the same libata code as the SATA drivers.
[Important]	IDE Device Names Changed

The new IDE drivers now cause all IDE drives to have device names such as
/dev/sdX instead of /dev/hdX.

If the /etc/fstab or /etc/crypttab files reference these devices by name, they
must be migrated before the system can access those partitions.




Not sure if this would be the cause of it as rebooting remotely and updating
through YUM, would not be able to diagnose if harddisks weren't accessible.
Comment 3 Jarod Wilson 2007-06-04 16:00:41 EDT
Need console output to get an idea why the system isn't booting, but indeed, the
removal of the old IDE drivers was intentional.
Comment 4 WebMasters, Inc. Support 2007-06-04 17:04:36 EDT
I'm pretty sure this is a NOTABUG.  We didn't update /etc/fstab or anything to
change hardware locations to sdX as indicated in those release notes.  Sorry for
the confusion!
Comment 5 QingLong 2007-09-21 02:14:33 EDT
If this is NOT A BUG, then redhat/fedora appears to be subverted by microsift.
I guess next step will be adopting ``advanced'' nameing scheme: C:\, D:\, etc.
>:>

This ``intentional removal of the old IDE drivers'' and transition to SCSI API
leads to lots of problems. One critical point: scsi drives can only have
14 partitions, while IDE discs have 64 reserved minor numbers and can contain
62 partitions (zero is the whole disc and one partition is ``wasted' for EXT).
If fedora maintainers cannot imagine installations using more than 16 partitions
that doesn't mean they do not exist. And BTW, LVM is not an adequate replacement
for such partitioning as partitions could be used as RAID members,
while logical volumes do not.

This is just an example (and this partitioning problem DOES really exist),
there are other problems as well (performance, stability, reliability, etc).
That's why I call this ``solution'' idiotic and now tend giving up using fedora, 
fortunatelly, there are other Linux distributions. :(

Note You need to log in before you can comment on or make changes to this bug.