Bug 24227 - gphoto - trouble when selecting device
Summary: gphoto - trouble when selecting device
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gphoto   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-17 18:15 UTC by Inger Karin Haarbye
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-17 21:48:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Inger Karin Haarbye 2001-01-17 18:15:24 UTC
I have kamera kodak dc280, and I use it with usb (dc2xx module -
/dev/usb/dc2xx0).
After some trouble with selecting device in beta1 and beta2,(bug
#23213) I upgraded to gphoto-4.3-10 (rawhide, recompiled src-rpm).

I still have problem. When I first time select camera and device,
everything is OK, and next time I open gphoto it works - if I don't try to
look at the configuration again and press "save". Looks like gphoto then
will try to open the device once again, and get the "please chech the
permissions" and "failed to open /dev/usb/dc2xx0" error.

Now with "strace -eopen gphoto", everything looks OK so far, the last lines:


open("/root/.gphoto/gphotorc", O_RDONLY) = 4
open("/dev/usb/dc2xx0", O_RDWR|O_NONBLOCK) = 4
state_machine_set_baud: tcgetattr: Inappropriate ioctl for device
Assuming USB connection.

Then I try "configuration" - and "save" - and I get:

open("/dev/usb/dc2xx0", O_RDWR)         = -1 EBUSY (Device or resource busy)
open("/dev/usb/dc2xx0", O_RDWR|O_NONBLOCK) = -1 EBUSY (Device or resource busy)
state_machine_construct: open: Device or resource busy
kdc240_initialize: could not create state machine!

Maybe it is nok the right thing to do to press "save" when the
configuration is OK already, but anyway, I don't think I like the way
gphoto is doing this.

Comment 1 Tim Waugh 2001-01-17 18:47:39 UTC
I've had a look at this, and it's basically a bit of a headache to fix.  I've reported it to the upstream maintainers.

Comment 2 Inger Karin Haarbye 2001-01-17 19:36:06 UTC
This is working OK in gphoto-4.3-8 in RH7.

Comment 3 Tim Waugh 2001-01-17 19:38:42 UTC
With a USB camera?

Comment 4 Inger Karin Haarbye 2001-01-17 20:04:31 UTC
Yes. I have not seen _this_ bug before... But gphoto is not very stable.

Comment 5 Tim Waugh 2001-01-17 21:45:58 UTC
It may appear to be working in -8, but I expect it will fail if you try it
several times in a row.


Comment 6 Tim Waugh 2001-10-19 13:04:03 UTC
Really, the solution will be to switch over to gphoto2 when it is released.



Note You need to log in before you can comment on or make changes to this bug.