Bug 242272 - Xorg crashes with savage driver (Caught signal 11)
Xorg crashes with savage driver (Caught signal 11)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-savage (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 17:54 EDT by Ivan Mironenko
Modified: 2009-01-09 02:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:06:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg Log (49.06 KB, application/octet-stream)
2007-06-02 17:54 EDT, Ivan Mironenko
no flags Details
Xorg.log (43.51 KB, application/octet-stream)
2007-11-09 16:02 EST, Ivan Mironenko
no flags Details
xorg.conf (1.25 KB, application/octet-stream)
2007-11-09 16:02 EST, Ivan Mironenko
no flags Details

  None (edit)
Description Ivan Mironenko 2007-06-02 17:54:55 EDT
Description of problem:

Xorg crashes when starting any 3D application or trying to enable "Desktop
effects" in Gnome.

According to the log, it crashes in /savage_drv.so(SavageDoAdjustFrame+0x9b) 

The bug "was there" starting from FC6.


Steps to Reproduce:
1. For example start PPracer, or powermanga, or try enabling "Desktop effects in
Gnome
  
Actual results:


Expected results:


Additional info:
Comment 1 Ivan Mironenko 2007-06-02 17:54:55 EDT
Created attachment 155999 [details]
Xorg Log
Comment 2 Matěj Cepl 2007-10-02 17:48:24 EDT
Since this bugzilla report was filed, there have been several updates, which may
have resolved this issue. Users who have experienced this problem are encouraged
to upgrade their system to the latest version of their distribution available.

Please, if you experience this problem on the up-to-date system, let us now in
the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as
INSUFFICIENT_DATA. Thank you.
Comment 3 Ivan Mironenko 2007-11-09 16:02:10 EST
Created attachment 253471 [details]
Xorg.log
Comment 4 Ivan Mironenko 2007-11-09 16:02:57 EST
Created attachment 253481 [details]
xorg.conf
Comment 5 Ivan Mironenko 2007-11-09 16:06:17 EST
I have updated my system to Fedora 8 and the bug is still present.
When I push "Enable Desktop Effects" in gnome, xorg crashes and I am back to
login screen.
I have added new xorg.conf and xorg.log 
Comment 6 Bjoern Rasmussen 2008-02-02 05:39:14 EST
I also have had this bug in the last Fedora releases (on a laptop equiped with a
ProSavage KN133 /TwisterK).  The bug is still there, on my updated Fedora 8 system.

In addition, if I hit Ctrl-Alt-F8, the display and keyboard dies (while the rest
of the system is up).  Hitting Ctrl-Alt-[F1-F7] works normally.  This behavior
is probably not part of this bug.  Perhaps Ivan can test this?
Comment 7 Bjoern Rasmussen 2008-02-02 05:51:01 EST
Isn't this the same bug as 426743?
Comment 8 Ivan Mironenko 2008-02-02 17:04:49 EST
The bug is not the same because in 426743 all OpenGL applications fail to start
and return "wait event returned -14", but Xorg server works fine after that.

However, the patch provided for the bug 426743 solved Xorg crashes as well.

I took already patched rpms with kernel DRM modules and xorg-x11-drv-savage from   
http://forums.fedoraforum.org/showthread.php?p=930814
and now all 3D applications run fine (although I have not tried 3D desktop yet)
Comment 9 Bjoern Rasmussen 2008-02-03 12:43:04 EST
Thanks Ivan!  The patched kernel and the driver worked well for me too!  It even
fixed the Ctrl-Alt-F8 problem.  Thanks again :-)
Comment 10 Bug Zapper 2008-11-26 02:16:38 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-01-09 02:06:57 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.