Bug 242279 - yumex ignored dependencies when installing
Summary: yumex ignored dependencies when installing
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: 7
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-02 22:42 UTC by Tom Horsley
Modified: 2008-05-15 17:32 UTC (History)
2 users (show)

Fixed In Version: 1.9.9-1.0.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-15 17:32:03 UTC


Attachments (Terms of Use)
output from package-cleanup --problems (5.49 KB, text/plain)
2007-06-02 22:42 UTC, Tom Horsley
no flags Details

Description Tom Horsley 2007-06-02 22:42:19 UTC
Description of problem:

I just installed x86_64 fedora 7 from DVD, did a "yum install yumex", then
ran yumex to install a slew of additional stuff not on the DVD image. Among
the things I installed (which I have so far noticed are messed up) are
claws-mail (along with lots of claws-mail plugins) and bogofilter. The
claws-mail rpm says it depends on compface and libetpan (I ran rpm -q -R
to be sure, and they are listed), and bogofilter says it depends on libgsl,
yet none of those libraries were installed. The tools wouldn't run till
I explicitly installed those libs.


Version-Release number of selected component (if applicable):
yum-updatesd-3.2.0-1.fc7
yum-metadata-parser-1.1.0-2.fc7
yumex-1.9.6-1.0.fc7
yum-3.2.0-1.fc7
yum-utils-1.1.4-1.fc7


How reproducible:

I had similar problems in test4 and figured I just thumb fingered something,
but it has happened again on f7 final with my reinstall. In fact, I just
rand package-cleanup --problems and I see a whole slew of other missing
libraries (I'll attache the listing), all for things I installed in my
initial yumex run (mplayer, vlc, etc).

Steps to Reproduce:
1. install f7 x86_64
2. install yumex
3. use yumex to install gobs of additional packages
  
Actual results:

loads of missing libraries

Expected results:

dependencies should have been added and installed

Additional info:

Obviously I have no idea if this is a yumex problem only or it is in
the lower level yum layers yumex uses.

Comment 1 Tom Horsley 2007-06-02 22:42:20 UTC
Created attachment 156002 [details]
output from package-cleanup --problems

Comment 2 Tom Horsley 2007-06-03 18:58:14 UTC
Seems like this probably isn't a yumex bug, but a yum bug. I've just
submitted bug 242368 after installing i386 fedora 7 in a new partition
and running into the same missing dependency problems using pirut to
add the additional packages as I had using yumex on the 64 bit f7
install.


Comment 3 Tim Lauridsen 2007-06-12 06:38:47 UTC
This is caused by a bug in yum, it is fixed in upstream yum cvs and will be
available in yum 3.2.1.
I have made a temporary work around to solve this in current yumex SVN, it will
be  available in next yumex release.

Comment 4 Fedora Update System 2007-06-12 19:57:31 UTC
yumex-1.9.9-1.0.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Callum Macdonald 2007-06-13 10:46:20 UTC
This bug appears to have been resolved for me (it caused some major headaches).
Thanks for the 1.9.9-1.0.fc7 update, much appreciated.

Comment 6 Fedora Update System 2007-06-18 16:39:53 UTC
yumex-1.9.9-1.0.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Tom Horsley 2007-08-30 11:37:23 UTC
Its back :-).

yumex-2.0.1-1.fc7, yum-3.2.2-1.fc7

I ran updates yesterday which tried to pull down a new rpmdevtools and
elfutils-libs. The dependency analysis added fakeroot as a dependency
of rpmdevtools.

When it tried to run the transaction, the elfutils-libs signature problem
that was discussed in the fedora users mailing list cropped up, so I went
to the queue page, removed all the elfutils related rpms from the queue and
said process queue.

Following that update, package-cleanup --problems said that fakeroot was
missing, so somehow fakeroot disappeared from the transaction when I edited
the queue and tried again (exactly the same circumstance that happened
when I first submitted this bug). 

Comment 8 Tim Lauridsen 2007-09-28 10:47:16 UTC
Please retest with current version of yum-3.2.5

Comment 9 Simon Luke 2007-10-14 20:51:38 UTC
It's probably a yumex error. After selecting packages, the dependency checking
happens and the dependencies along with the selected packages appear in the
download dialog.

After you click it goes into downloading the rpms, if a download fails (i.e.
lose network connection), or the installation process fails, yumex simply stops
- allowing you to continue with whatever. It has _not_ however added the
dependencies to the package queue, and when you reprocess the queue it fails to
recheck them. Thus it downloads the ones you have selected without the
dependencies, then installs them causing problems.

I have a dodgy wireless connection where I am and keep running into this problem
:( nvm.

Comment 10 Romain Janvier 2007-10-17 05:27:33 UTC
I've also seen this problem with yum-3.2.5-1.fc7 and yumex-2.0.2-1.fc7. If you
try to install something with dependencies, when yumex asks you to download and
install everything, including the dependencies, you you click on "cancel" then
"proceed queue" again, the dependencies are not presented in the list of
packages to download and install.

If you exit yumex and restart it, everything works fine again.

Comment 11 Tim Lauridsen 2007-10-17 06:07:03 UTC
the yum depsolver has been a moving target lately, so this error keep popping up.
I will make it work with current yum

Comment 12 Tim Lauridsen 2007-10-17 09:55:01 UTC
I have tried the following with:
yumex-2.0.2-1.fc8
yum-3.2.7-1.fc8

Test case 1:
Selected BackupPC and 'process queue'
got a confirmation dialog with some deps.
press 'cancel' and 'process queue' again
Got the same confirmation dialog with same deps.

Test case 2:
removed openoffice.org base etc.
Selected 'openoffice.org-writer & openoffice.org-langpack-da_DK'
'Process Queue' & 'Ok' on confirmation dialog.
Disabled my wireless connection while downloading
pressed the 'Skip' button to skip mirror and provoke a lot of timeout errors.
Af the error dialog, i selected 'Process Queue' again and got the same
confirmation dialog with the same deps.

Try update to yum-3.2.7 in updates-testing and try again.
(yum --enablerepo=updates-testing update yum)


Comment 13 Tim Lauridsen 2008-02-21 12:52:02 UTC
Do you still have this issue ?

Comment 14 Tom Horsley 2008-02-21 13:12:04 UTC
I certainly haven't seen it for a long time. I'm not sure
that proves it is gone :-).

Comment 15 Bug Zapper 2008-05-14 12:44:34 UTC
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.