This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 242291 - Can't install windows with qemu/kvm without manually editing a xml file
Can't install windows with qemu/kvm without manually editing a xml file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 20:49 EDT by vfiend
Modified: 2008-03-04 08:46 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.5.3-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:38:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vfiend 2007-06-02 20:49:14 EDT
Description of problem: Attempting to install from a windows cd in virt-manager
with kvm, after windows shuts down in the middle of the install, the cd image
vanishes and the user must locate a xml file in /etc/libvirt/qemu/ and manually
add the cd image back before the install can be continued and completed.
Probably virt manager should not try to be so smart, leave the cd mounted and
users can remove it themselves after the install completes successfully.


Version-Release number of selected component (if applicable):
virt-manager-0.4.0-2.fc7
Comment 1 Alejandro Gonzalez Hernandez - Imoq 2007-06-05 12:43:24 EDT
I was about to submit this bug as well, but I will just add a "me too" instead.

Had the same problem trying to install a RHL 7.3 (don't ask, I needed something
from that system), after the installer finishes with CD1 and asks for CD2, there
is no way I can insert the new CD and RHL 7.3's anaconda to recognize it. Had to
do a minimum-minimum install to use only 1 CD.

btw, vfiend, can you please post the lines you had to add to the XML file? Thanks!
Comment 2 vfiend 2007-06-05 22:19:41 EDT
I can't remember exactly what I added, I created a new virtual machine with the
same settings, then looked at the new file and saw the section it automatically
created for the disc. I then copy-pasted the section from the new file into the
old file and deleted the new virtual machine, after you install you can then
remove the cd image/drive from the GUI.

Note: I think the services for qemu/virt manager need to be restarted after this
or possibly stopped before you do it, I'm not sure. This is just a quick dirty
work around I stumbled through with trial and error.
Comment 3 Deependra Singh Shekhawat 2007-06-11 06:56:59 EDT
I think the patch to this bug was applied 5 days ago.
http://hg.et.redhat.com/virt/applications/virtinst--devel

I am not sure. Maybe the developer have more information about it. If it's the
correct one I guess probably some more time before it comes to fedora7-updates.

Comment 4 Josh Cogliati 2007-06-27 11:16:37 EDT
Using changeset 205 65ea24a40b29 from
http://hg.et.redhat.com/virt/applications/virtinst--devel allowed me to install
Win XP from a iso file.  

$ hg clone http://hg.et.redhat.com/virt/applications/virtinst--devel
$ cd virtinst--devel/
$ sudo ./virt-install
... (answer questions)

So this does appear to be solved with with the current version of virtinst.  The
patch that Deependra mentions (change 202) will not easily apply to the version
103 that is in redhat since it depends on other changes made since 103 was
released.    
Comment 5 Daniel Berrange 2007-06-27 11:19:42 EDT
We will be updating to the new upstream version of python-virtinst in the near
future, since as you note, backporting this is not easy.....
Comment 6 Daniel Berrange 2007-07-15 16:28:15 EDT
Upstream virt-manager now also has the ability to add & remove CDROM devices
which will make Windows installs easier. This will appear in next Fedora update.
Comment 7 Red Hat Bugzilla 2007-07-24 22:12:16 EDT
change QA contact
Comment 8 Fedora Update System 2008-01-11 17:26:44 EST
virt-manager-0.5.3-1.fc7, gtk-vnc-0.3.2-1.fc7, python-virtinst-0.300.2-1.fc7, virt-viewer-0.0.2-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager gtk-vnc python-virtinst virt-viewer'
Comment 9 Fedora Update System 2008-01-22 10:38:01 EST
virt-manager-0.5.3-1.fc7, gtk-vnc-0.3.2-1.fc7, python-virtinst-0.300.2-1.fc7, virt-viewer-0.0.2-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Brian L Scipioni 2008-03-04 08:46:57 EST
I think this persists.  I have these versions installed below.  During the
install I am asked for D:\i386\asms which is right there on the CD where the
install done from, but it just keeps asking for it, so I assume this is the same
problem.

virt-manager.i386                        0.5.3-1.fc7            installed       
virt-viewer.i386                         0.0.2-1.fc7            installed
gtk-vnc.i386                             0.3.2-1.fc7            installed
python-virtinst.noarch                   0.300.2-2.fc7          installed

Note You need to log in before you can comment on or make changes to this bug.