Bug 242295 - [pata_sis] Intall Hangs When LoadingDriver
[pata_sis] Intall Hangs When LoadingDriver
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 21:18 EDT by William Makowski
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.22.9-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 09:26:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Information from Cntl+Alt+F4 screen (1.86 KB, text/plain)
2007-06-02 21:18 EDT, William Makowski
no flags Details
Configuration diff between delivered and custom kernel for f7 (1.81 KB, text/plain)
2007-06-04 10:16 EDT, William Makowski
no flags Details
dmesg from working system (13.41 KB, text/plain)
2007-06-05 14:27 EDT, William Makowski
no flags Details
dmesg for SIS630 chipset for Comment #8 (20.57 KB, text/plain)
2007-06-17 21:58 EDT, TC
no flags Details
dmesg for SI745 chipset for Comment #8 (17.79 KB, text/plain)
2007-06-17 22:00 EDT, TC
no flags Details
dmesg output for kernel-2.6.22-2.fc7.i686.rpm (Dave Jone's WIP kernel) (20.81 KB, text/plain)
2007-07-11 21:20 EDT, TC
no flags Details
Extract from dmesg and syslog for pata_sis (3.62 KB, text/plain)
2007-10-09 12:43 EDT, William Makowski
no flags Details

  None (edit)
Description William Makowski 2007-06-02 21:18:13 EDT
Description of problem: I attempted to install Fedora 7 using CD's created from
the boot.iso and also the rescue CD.  The installation process hangs in the
Loading SCSI driver step, specifically when Loading pata_sis driver.  This looks
to be hardware related.  There are only IDE drives in this system.  I tried the
install adding the noscsi kernel parameter, but it still hangs.  FC6 is able to
install and runs fine on this hardware.  I've seen a few messages about the
pata_sis driver and problems with older chipsets on the net, but nothing similar
to what I am experiencing.


Version-Release number of selected component (if applicable): 


How reproducible: Everytime.


Steps to Reproduce:
1. Begin install using either boot CD or rescue CD.
2. It then tries loading SCSI driver.
3.
  
Actual results: Install Hangs


Expected results:  Continue with installation of F7.


Additional info: See attached file with log from Cntl+Alt+F4.

Motherboard: K7SEM
Chipset: SiS730S
Processor: AMD 1.150 GHz
Memory: 256M

_Output_from_lscpi_
livecd ~ # lspci
0000:00:00.0 Host bridge: Silicon Integrated Systems [SiS] 730 Host (rev 02)
0000:00:00.1 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev
d0)0000:00:01.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513
(LPC Bridge)
0000:00:01.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 07)
0000:00:01.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 07)
0000:00:01.4 Multimedia audio controller: Silicon Integrated Systems [SiS] SiS
PCI Audio Accelerator (rev 02)
0000:00:02.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI
bridge (AGP)
0000:00:0b.0 Communication controller: Ambient Technologies Inc HaM
controllerless modem (rev 02)
0000:00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
0000:01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS]
630/730 PCI/AGP VGA Display Adapter (rev 31)
Comment 1 William Makowski 2007-06-02 21:18:13 EDT
Created attachment 156009 [details]
Information from Cntl+Alt+F4 screen
Comment 2 William Makowski 2007-06-04 10:13:18 EDT
Since my initial posting I have installed f7 by building my own boot CD.  The
new boot CD was created using the f7 boot.iso with a modified initrd.img and the
vmlinuz kernel from the FC6 install CD.  initrd.img was changed to include the
.bootstamp from f7 rather than what was included with FC6.  No other changes
were made.

Once booted with the new boot CD I performed an NFS Installation Setup. It went
through to completion without any issues.  After installation I tried to reboot
with the delivered kernel-2.6.21-1.3194.fc7.i686.rpm and met with messages very
similar to what is in my previous attachment.

I was able to get the system up and running using my boot CD and then NFS to a
f7 rescue image.  My next step was to compile a new 2.6.21 kernel from source
using kernel-2.6.21-1.3194.fc7.src.rpm.  By making changes to the IDE
configuration (see attached diff) I built a kernel that works with my system. 
The changes in the SCSI device support section of the config file happened on
their own.
Comment 3 William Makowski 2007-06-04 10:16:18 EDT
Created attachment 156077 [details]
Configuration diff between delivered and custom kernel for f7
Comment 4 Dave Jones 2007-06-05 13:52:42 EDT
ideally, we want the new libata driver to work, and not have to go back to the
old unmainted CONFIG_IDE drivers.
Comment 5 Alan Cox 2007-06-05 14:01:29 EDT
Can you attach a dmesg of your now working system so I can see the drive
configuration you have 
Comment 6 William Makowski 2007-06-05 14:27:23 EDT
Created attachment 156258 [details]
dmesg from working system

Thanks for the reply, here is the dmesg for this system.  Only change since
original post was that I found and added 128M of RAM.  Drives are still the
same.
Comment 7 Hans de Goede 2007-06-10 07:41:40 EDT
Correcting summary.
Comment 8 TC 2007-06-17 21:56:01 EDT
I have two motherboards, an ASUS TUSI-M (SIS 630 chipset Pentium III MB) and an
ASUS A7S333 (SIS 745 chipset Athlon MB) which exhibit non-fatal IDE errors. Both
were supposed to be rated for UDMA 100, and both hard disks are capable of
supporting UDMA 100 (one is a Seagate 120GB while the other is a Seagate 160GB).

I've managed to install Fedora 7 on both machines.

lspci -v for SIS 630 IDE controller:
00:00.1 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
(prog-if 80 [Master])
        Subsystem: ASUSTeK Computer Inc. Unknown device 80e1
        Flags: bus master, fast devsel, latency 128
        [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [size=8]
        [virtual] Memory at 000003f0 (type 3, non-prefetchable) [size=1]
        [virtual] Memory at 00000170 (32-bit, non-prefetchable) [size=8]
        [virtual] Memory at 00000370 (type 3, non-prefetchable) [size=1]
        I/O ports at d800 [size=16]

For the SIS 630, pata_sis retries at UDMA 100 three times, then downshifts to
UDMA 66 at which point it will proceed with booting.


lspci -v for SIS 745 IDE controller:
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
(prog-if 80 [Master])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8083
        Flags: bus master, fast devsel, latency 128
        [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [size=8]
        [virtual] Memory at 000003f0 (type 3, non-prefetchable) [size=1]
        [virtual] Memory at 00000170 (32-bit, non-prefetchable) [size=8]
        [virtual] Memory at 00000370 (type 3, non-prefetchable) [size=1]
        I/O ports at d800 [size=16]


For the SIS 745, pata_sis does not exhibit any read errors though there is a
warning given in dmesg.

ATA: abnormal status 0x7F on port 0x00010177
ATA: abnormal status 0x7F on port 0x00010177

Strange thing is that both IDE controllers are supposedly of the same type
according to lspci.
Comment 9 TC 2007-06-17 21:58:35 EDT
Created attachment 157244 [details]
dmesg for SIS630 chipset for Comment #8

This is the dmesg for F7 with updated kernel 2.6.21-1.3228.f7.
System will eventually boot although it goes through the IDE soft reset three
times before using UDMA 66 to boot.
Comment 10 TC 2007-06-17 22:00:33 EDT
Created attachment 157245 [details]
dmesg for SI745 chipset for Comment #8

dmesg for SIS 745 motherboard. UDMA 100 works correctly (with a warning about
abnormal status).
Comment 11 Alan Cox 2007-06-18 06:24:02 EDT
SiS745 one is just a debugging warning and harmless
SiS630 one should be fixed in the current upstream kernel
Comment 12 TC 2007-07-11 21:20:27 EDT
Created attachment 159024 [details]
dmesg output for kernel-2.6.22-2.fc7.i686.rpm (Dave Jone's WIP kernel)

This is for SIS 630 chipset (ref. Comment #8).

I've tried Dave Jone's latest WIP kernel for Fedora 7 (2.6.22-2), and it still
exhibits the same error on IDE initialization. ATA1 will soft reset for 4 times
before using a slower UDMA speed and continue booting up.

However, there seems to be a regression on ATA2, where I have a IDE DVD Writer
attached on a 80-pin cable. dmesg output indicates that it is using UDMA 33
instead of the higher speeds.

Lastly, there's a kernel module crash which occured on insertion of my USB
stick. I'm not sure if it's related to this bug but I'm noting it here in any
case. The kernel seems to be able to recover from the crash and mount the USB
stick normally afterwards.
Comment 13 Alan Cox 2007-09-10 11:35:02 EDT
Thanks for the testing, I'll do some further digging
Comment 14 TC 2007-10-04 02:45:15 EDT
Re: Comment #9 and Comment #12.

The latest pata_sis driver in kernel-2.6.22.9-91.fc7 solves the SIS 630 ATA1
soft reset problem. It can access the hard disk immediately during the kernel
boot process now using UDMA 100.

However, ATA2 for both the SIS 630 and SIS 745 still defaults to UDMA 33 with
the 40-pin cable warning, even though the attached DVD drives are actually
capable of at least UDMA 66, since they have 80-pin cables attached.


Comment 15 William Makowski 2007-10-09 12:43:12 EDT
Created attachment 221491 [details]
Extract from dmesg and syslog for pata_sis

I'm having positive results with the SiS730S chipset for
kernel-2.6.22.9-91.fc7.  Attached are extracts from dmesg and syslog related to
pata_sis.  The system no longer hangs on boot and it properly identifies and
sets the UDMA modes without any hesitation.  Initially I thought it might still
be an issue because the system was crashing after being online for 1-2 hours
with similar messages.	Now I believe those crashes were heat related because
of the warm weather we've been experiencing.  I am not able to confirm the UDMA
66 issue identified by tcwan.  The CDROM on this system has a maximum of UDMA
33.  I will continue running using this kernel to make certain those crashes
were not related.  Thank you for your assistance.
Comment 16 William Makowski 2007-10-10 13:38:28 EDT
Just had another crash and I know this one is not heat related.  The following
info was sent to me by Logwatch.  Let me know if there is something else you
want me to look at or send.  If I have time I may swap out this hard drive to
make sure that isn't the culprit.

 WARNING:  Kernel Errors Present
             res 51/04:00:0b:00:00/00:00:00:00:00/00 Emask 0x1 (device error) ..
.:  1 Time(s)
             res 51/04:00:0b:ff:ff/00:00:00:00:00/00 Emask 0x1 (device error) ..
.:  1 Time(s)
Comment 17 Chuck Ebbert 2007-10-10 13:49:48 EDT
(In reply to comment #16)
> Just had another crash and I know this one is not heat related.  The following
> info was sent to me by Logwatch.  Let me know if there is something else you
> want me to look at or send.  If I have time I may swap out this hard drive to
> make sure that isn't the culprit.
> 
>  WARNING:  Kernel Errors Present
>              res 51/04:00:0b:00:00/00:00:00:00:00/00 Emask 0x1 (device error) ..
> .:  1 Time(s)
>              res 51/04:00:0b:ff:ff/00:00:00:00:00/00 Emask 0x1 (device error) ..
> .:  1 Time(s)
> 

Can you look in the log and find the complete set of messages from these events?
Comment 18 William Makowski 2007-10-11 00:21:05 EDT
Yes, found the messages (see below).  Interesting to note they were not anywhere
near the time of the system crash.  The final entry before the crash was... Oct
10 03:50:49 frodo ntpd[1804]: synchronized to 216.157.21.135, stratum 3.  As you
can see the messages below happened the previous day.

Oct  9 02:51:41 frodo gconfd (makowski-2450): Resolved address "xml:readwrite:/h
ome/makowski/.gconf" to a writable configuration source at position 0
Oct  9 02:55:22 frodo kernel: ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 act
ion 0x0
Oct  9 02:55:22 frodo kernel: ata1.00: cmd b0/da:00:00:4f:c2/00:00:00:00:00/00 t
ag 0 cdb 0x0 data 0 
Oct  9 02:55:22 frodo kernel:          res 51/04:00:0b:ff:ff/00:00:00:00:00/00 E
mask 0x1 (device error)
Oct  9 02:55:22 frodo kernel: ata1.00: configured for UDMA/100
Oct  9 02:55:22 frodo kernel: ata1: EH complete
Oct  9 02:55:22 frodo kernel: sd 0:0:0:0: [sda] 39102336 512-byte hardware secto
rs (20020 MB)
Oct  9 02:55:22 frodo kernel: sd 0:0:0:0: [sda] Write Protect is off
Oct  9 02:55:22 frodo kernel: sd 0:0:0:0: [sda] Write cache: enabled, read cache
: enabled, doesn't support DPO or FUA
Oct  9 02:55:23 frodo kernel: ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 act
ion 0x0
Oct  9 02:55:23 frodo kernel: ata1.00: cmd b0/da:00:00:4f:c2/00:00:00:00:00/00 t
ag 0 cdb 0x0 data 0 
Oct  9 02:55:23 frodo kernel:          res 51/04:00:0b:00:00/00:00:00:00:00/00 E
mask 0x1 (device error)
Oct  9 02:55:23 frodo kernel: ata1.00: configured for UDMA/100
Oct  9 02:55:23 frodo kernel: ata1: EH complete
Oct  9 02:55:23 frodo kernel: sd 0:0:0:0: [sda] 39102336 512-byte hardware secto
rs (20020 MB)
Oct  9 02:55:23 frodo kernel: sd 0:0:0:0: [sda] Write Protect is off
Oct  9 02:55:23 frodo kernel: sd 0:0:0:0: [sda] Write cache: enabled, read cache
: enabled, doesn't support DPO or FUA
Oct  9 02:55:34 frodo ntpd[1855]: synchronized to 69.60.124.59, stratum 3
Comment 19 William Makowski 2007-10-17 10:24:14 EDT
The system has been running continuously on kernel-2.6.22.9-91.fc7 for about a
week without incident.  After the crash I used fsck on the filesystem and it
made a number of repairs.  At this point I don't want to jinx myself, but I
believe the bug has been resolved for this particular system.  I plan to move
onto F8 soon, but in the meantime will report any inconsistencies.

Note You need to log in before you can comment on or make changes to this bug.