Bug 242301 - Fedora 7 RTL8169 / IPW2200 Boot Hang
Summary: Fedora 7 RTL8169 / IPW2200 Boot Hang
Status: CLOSED DUPLICATE of bug 242572
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: i686 Linux
low
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-03 04:14 UTC by Mike McGuire
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-07 17:37:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McGuire 2007-06-03 04:14:39 UTC
Fedora 7 hangs right before graphical login.  If network cable is plugged you
must remove it to continue boot sequence.  If the network is unplugged during
boot, you must plug it in to continue boot sequence.  If Network Manager
services are disabled, then computer boots fine whether cable is plugged in or
not.  The chipset in question:

 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet
(rev 10)

Dump of the log:

Jun  2 20:13:52 localhost kernel: r8169: eth0: link up
Jun  2 20:14:10 localhost kernel: r8169: eth0: link up
Jun  2 20:14:10 localhost kernel: BUG: soft lockup detected on CPU#0!
Jun  2 20:14:10 localhost kernel:  [<c0451f3e>] softlockup_tick+0xa5/0xb4
Jun  2 20:14:10 localhost kernel:  [<c042e930>] update_process_times+0x3b/0x5e
Jun  2 20:14:10 localhost kernel:  [<c043d2bd>] tick_sched_timer+0x78/0xbb
Jun  2 20:14:10 localhost kernel:  [<c0439df5>] hrtimer_interrupt+0x12b/0x1b6
Jun  2 20:14:10 localhost kernel:  [<c043d245>] tick_sched_timer+0x0/0xbb
Jun  2 20:14:10 localhost kernel:  [<c0408534>] timer_interrupt+0x2c/0x32
Jun  2 20:14:10 localhost kernel:  [<c04521aa>] handle_IRQ_event+0x1a/0x3f
Jun  2 20:14:10 localhost kernel:  [<c04535ea>] handle_level_irq+0x81/0xc7
Jun  2 20:14:10 localhost kernel:  [<c04072c7>] do_IRQ+0xb8/0xd1
Jun  2 20:14:10 localhost kernel:  [<c04058ff>] common_interrupt+0x23/0x28
Jun  2 20:14:10 localhost kernel:  [<c04058ff>] common_interrupt+0x23/0x28
Jun  2 20:14:10 localhost kernel:  [<c0561704>] yenta_interrupt+0x13/0xb4
Jun  2 20:14:10 localhost kernel:  [<c04521aa>] handle_IRQ_event+0x1a/0x3f
Jun  2 20:14:10 localhost kernel:  [<c04535ea>] handle_level_irq+0x81/0xc7
Jun  2 20:14:10 localhost kernel:  [<c0453569>] handle_level_irq+0x0/0xc7
Jun  2 20:14:10 localhost kernel:  [<c04072bb>] do_IRQ+0xac/0xd1
Jun  2 20:14:10 localhost kernel:  [<c04058ff>] common_interrupt+0x23/0x28
Jun  2 20:14:10 localhost kernel:  [<c042b2dc>] __do_softirq+0x54/0xba
Jun  2 20:14:10 localhost kernel:  [<c04071b7>] do_softirq+0x59/0xb1
Jun  2 20:14:10 localhost kernel:  [<c0453569>] handle_level_irq+0x0/0xc7
Jun  2 20:14:10 localhost kernel:  [<c042b194>] irq_exit+0x38/0x6b
Jun  2 20:14:10 localhost kernel:  [<c04072cc>] do_IRQ+0xbd/0xd1
Jun  2 20:14:10 localhost kernel:  [<c04058ff>] common_interrupt+0x23/0x28
Jun  2 20:14:10 localhost kernel:  [<f8b0007b>] rtl8169_init_one+0x5c7/0x9d7 [r8169]
Jun  2 20:14:10 localhost kernel:  [<c060171d>] _spin_unlock_irqrestore+0x8/0x9
Jun  2 20:14:10 localhost kernel:  [<f8aff1f7>] rtl8169_open+0x139/0x194 [r8169]
Jun  2 20:14:10 localhost kernel:  [<c05a2f8d>] dev_open+0x2b/0x62
Jun  2 20:14:10 localhost kernel:  [<c05a19e1>] dev_change_flags+0x47/0xe4
Jun  2 20:14:10 localhost kernel:  [<c05a977b>] rtnl_setlink+0x264/0x365
Jun  2 20:14:10 localhost kernel:  [<c05a9517>] rtnl_setlink+0x0/0x365
Jun  2 20:14:10 localhost kernel:  [<c05a8dad>] rtnetlink_rcv_msg+0x1c1/0x1e6
Jun  2 20:14:10 localhost kernel:  [<c05b4e19>] netlink_run_queue+0x50/0xbe
Jun  2 20:14:10 localhost kernel:  [<c05a8bec>] rtnetlink_rcv_msg+0x0/0x1e6
Jun  2 20:14:10 localhost kernel:  [<c05a8bab>] rtnetlink_rcv+0x25/0x3d
Jun  2 20:14:10 localhost kernel:  [<c05b51b6>] netlink_data_ready+0x12/0x4c
Jun  2 20:14:10 localhost kernel:  [<c05b426a>] netlink_sendskb+0x19/0x30
Jun  2 20:14:10 localhost kernel:  [<c05b5198>] netlink_sendmsg+0x277/0x283
Jun  2 20:14:10 localhost kernel:  [<c0599180>] sock_sendmsg+0xd0/0xeb
Jun  2 20:14:10 localhost kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun  2 20:14:10 localhost kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun  2 20:14:10 localhost kernel:  [<c04e7100>] copy_from_user+0x3a/0x66
Jun  2 20:14:10 localhost kernel:  [<c059932d>] sys_sendmsg+0x192/0x1f7
Jun  2 20:14:10 localhost kernel:  [<c0599e0d>] sys_recvmsg+0x1b9/0x1cd
Jun  2 20:14:10 localhost kernel:  [<c04e7350>] copy_to_user+0x3c/0x50
Jun  2 20:14:10 localhost kernel:  [<c0599c3c>] move_addr_to_user+0x50/0x68
Jun  2 20:14:13 localhost kernel:  [<c059a0d6>] sys_getsockname+0x9f/0xb0
Jun  2 20:14:13 localhost kernel:  [<c06016f4>] _spin_lock_bh+0x8/0x18
Jun  2 20:14:13 localhost kernel:  [<c059adb6>] release_sock+0x12/0x9d
Jun  2 20:14:13 localhost kernel:  [<c059a4fc>] sys_socketcall+0x240/0x261
Jun  2 20:14:13 localhost kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jun  2 20:14:13 localhost kernel:  =======================
Jun  2 20:14:13 localhost kernel: r8169: eth0: link down


Version-Release number of selected component (if applicable):

Fedora 7


How reproducible:

Always


Steps to Reproduce:
1. Turn on computer
2.
3.
  
Actual results:


Expected results:

Normal boot


Additional info:

Comment 1 Mike McGuire 2007-06-03 13:17:37 UTC
This also happens when eth0 NIC is configured for Static or DHCP

Comment 2 John W. Linville 2007-06-07 14:14:09 UTC
Any reason you included ipw2200 in the subject?  I don't see any obvious 
reason to mention it.  Can you disable the wireless card in the BIOS?  If you 
do, does that change this bug?  Or do you still get the hang w/ the log 
references to r8169?

Comment 3 Mike McGuire 2007-06-07 16:30:22 UTC
The reason I included ipw2200 is if the ethernet cable is plugged in during 
boot, right before the login process it will hang and spew the above trace, 
when I remove the cable it will continue to boot, but NetworkManager will 
still show it connected as a wired device and I physically have to select a 
wireless device to get it connected wirelessly.  
I can't disable the wireless in BIOS, but I have a hardware switch that has 
been used to disable the wireless, with the same results, It hangs and 
displays the same RTL8169 reference.  I even tried to trick the ethernet port 
by using a loopback plug with the same hang results.


Comment 4 John W. Linville 2007-06-07 16:55:19 UTC
Please try adding a line like this to /etc/modprobe.d/blacklist:

   blacklist ipw2200

And then reboot -- I would like to determine if ipw2200 is involved or 
not...thanks!

Comment 5 John W. Linville 2007-06-07 17:37:45 UTC

*** This bug has been marked as a duplicate of 242572 ***


Note You need to log in before you can comment on or make changes to this bug.